Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161489 - kde preferences menu is not populated properly
Summary: kde preferences menu is not populated properly
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 171491
TreeView+ depends on / blocked
 
Reported: 2005-06-23 17:59 UTC by Orion Poplawski
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

Fixed In Version: 2.20.1-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-18 09:35:47 UTC


Attachments (Terms of Use)

Description Orion Poplawski 2005-06-23 17:59:42 UTC
Description of problem:
Fresh KDE only FC4 install.  Testing out firefox and thunderbird.  I have no
option to open a mail client when clicking on mailto: urls in firefox. 
Likewise, http: urls in thunderbird don't work.

Is there anything else that needs to be installed/configured for this to work?

Version-Release number of selected component (if applicable):
firefox-1.0.4-4

How reproducible:
everytime

Actual results:
links don't work

Expected results:
mailto: link should bring up mail client (configured somewhere?)
http: link should bring up web client (configured somewhere?)

Additional info:

Comment 1 Orion Poplawski 2005-06-23 18:42:02 UTC
Okay, looks like by installing control-center and running
gnome-default-applications-properties the urls work and I can change the
settings.  It looks like the gnome-default-applications.desktop file is
configured to only be display in gnome.  Any reason not to show it in KDE?  Is
there an alternative way to configure in KDE?

Comment 2 Warren Togami 2005-09-30 19:52:48 UTC
gnome-default-applications.desktop's OnlyShowIn=GNOME; is wrong for Fedora,
because we rely on GNOME's preferred application choice for browser and mail URI
launching in all other applications.  Thank you for bringing this to my attention.

Comment 3 Orion Poplawski 2005-12-13 21:42:16 UTC
In KDE, now shows up in Preferences -> More Preferences -> Preferred
Applications.  Any chance we can get it out of "More Preferences"?

Comment 4 Warren Togami 2005-12-14 04:29:06 UTC
I personally would want it in the regular "Preferences" menu, but my guess is
that the Desktop team wants to hide it in order to simplify the desktop as much
as possible because the defaults should best for users.  Unfortunately the
defaults are NOT fine for the e-mail client for many users... =(

Anyway let's see what some desktop people think.


Comment 5 Orion Poplawski 2006-02-15 23:54:05 UTC
On rawhide now, I have a "Preferences" menu whose only entry is "More
preferences".  This is silly.

Comment 6 David Lawrence 2006-04-18 20:29:50 UTC
NEEDINFO_ENG has been deprecated in favor of NEEDINFO or ASSIGNED. Changing
status to ASSIGNED for ENG review.

Comment 7 Matthias Clasen 2006-08-04 13:58:30 UTC
What is the story here ? Than, do we need to remove the OnlyShowIn=GNOME from
gnome-default-applications.desktop ?

Comment 8 Ngo Than 2007-02-14 15:07:12 UTC
i don't remember anymore. But it's no problem to remove  OnlyShowIn=GNOME from
gnome-default-applications.desktop

Comment 9 Warren Togami 2007-06-08 18:54:57 UTC
This is still an issue in F7.

Comment 10 Orion Poplawski 2007-10-17 20:05:09 UTC
OnlyShowIn=GNOME is still in gnome-default-applications.desktop.  Almost 2 1/2
years now.

Comment 11 Bastien Nocera 2007-10-18 09:35:47 UTC
Fixed in control-center-2.20.1-2


Note You need to log in before you can comment on or make changes to this bug.