Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161486 - Net SSH Perl module
Summary: Net SSH Perl module
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Warren Togami
QA Contact: David Lawrence
URL: http://forums1.itrc.hp.com/service/fo...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-23 17:44 UTC by tekion
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-04 02:51:21 UTC


Attachments (Terms of Use)

Description tekion 2005-06-23 17:44:13 UTC
Description of problem:
Using Net SSH Perl from CPAN, expeirencing slow ssh connection.  While
installing it, noticed Crypt::DH module takes a long time to install. Is there a
bug with Fedora that is not playing nice with Crypt::DH. Could it be the
different glibc version be affecting it?

Version-Release number of selected component (if applicable):


How reproducible:
all the time

Steps to Reproduce:
1. install Net::SSH::Perl
2.  try to connect with it
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 tekion 2005-06-23 19:32:03 UTC
takes over an hour to install Crypt::DH, so far I am only at this junction:
*** ExtUtils::AutoInstall version 0.56
*** Checking for dependencies...
[Core Features]
- Math::BigInt ...loaded. (1.73 >= 1.60)
*** ExtUtils::AutoInstall configuration finished.
Checking if your kit is complete...
Looks good
Writing Makefile for Crypt::DH
cp lib/Crypt/DH.pm blib/lib/Crypt/DH.pm
Manifying blib/man3/Crypt::DH.3pm
  /usr/bin/make  -- OK
Running make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0,
'inc', 'blib/lib', 'blib/arch')" t/00-compile.t t/01-dh.t
t/00-compile....ok
t/01-dh.........ok 18/21


Comment 2 Warren Togami 2005-07-04 02:51:21 UTC
CPAN modules are not the responsibility of the Fedora Project unless they are
packaged in Extras, in that case they are the responsibility of the package
owner.    Since you seem to be installing your own module manually, I must close
this NOTABUG.  You should either go upstream for help, or file it against glibc
if you are certain this a problem unique to our glibc.

Comment 3 Andreas Øye 2005-10-20 08:23:53 UTC
Connection time should be better if you install a perl binding for GMP to
improve performance of Math::BigInt. for instance Math::BigInt::GMP



Note You need to log in before you can comment on or make changes to this bug.