Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161482 - non-root users get unicode error on os.access
Summary: non-root users get unicode error on os.access
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: python
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mihai Ibanescu
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-23 17:28 UTC by Andrea Santilli
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-23 11:23:04 UTC


Attachments (Terms of Use)

Description Andrea Santilli 2005-06-23 17:28:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
This is what I get while running os.access as non-root user:
Traceback (most recent call last):
  File "/usr/bin/gnomeboyadvance", line 5, in ?
    gba = GnomeBoyAdvance()
  File "/usr/lib/python2.4/site-packages/gnomeboyadvance/GnomeBoyAdvance.py", line 54, in __init__
    self.mySettings = Settings.Settings()
  File "/usr/lib/python2.4/site-packages/gnomeboyadvance/Settings.py", line 24, in __init__
    if not self.__checkBinary(): self.tryFindBinary()
  File "/usr/lib/python2.4/site-packages/gnomeboyadvance/Settings.py", line 32, in __checkBinary
    return os.access(bin, os.X_OK )
TypeError: coercing to Unicode: need string or buffer, NoneType found


This seems to be an old bug as reported in http://mail.python.org/pipermail/python-dev/2005-March/051906.html

Version-Release number of selected component (if applicable):
2.4.1-2

How reproducible:
Always

Steps to Reproduce:
1. run a program containing os.access as non-root user.
  

Actual Results:  I got an unicode error

Additional info:

Comment 1 Mihai Ibanescu 2005-09-30 18:09:46 UTC
I cannot seem to reproduce this, do you have an example?


Note You need to log in before you can comment on or make changes to this bug.