Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161474 - Movies play in separate window in Openoffice instead of embedded
Summary: Movies play in separate window in Openoffice instead of embedded
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Fitzsimmons
QA Contact:
URL:
Whiteboard:
: 178727 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-23 16:42 UTC by zingale
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: 2.2.0-14.5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-17 09:12:23 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenOffice.org 68717 None None None Never

Description zingale 2005-06-23 16:42:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
After adding the Java Media Framework to the Tools/Options/Java/Class Path, I am able to add movies to an Impress presentation, but in slideshow mode, they play in a separate window instead of embedded in the slide itself.

With the official Openoffice.org 1.9.104 RPMs, the movie is embedded in the slide, as expected, so this is only a Fedora bug, not a general Openoffice.org bug.

Version-Release number of selected component (if applicable):
openoffice.org-impress-1.9.104-2

How reproducible:
Always

Steps to Reproduce:
1. add the Java Media Framework to the OOo class path
2. insert a supported movie type into a slide (MPEG-1 for example)
3.
  

Actual Results:  in slideshow mode, a separate window pops up to play the movie

Expected Results:  the movie should play embedded in the slide itself

Additional info:

Comment 1 Caolan McNamara 2005-07-07 15:09:05 UTC
err... how do I go about reproducing this exactly ? 

Comment 2 Caolan McNamara 2005-07-14 16:42:44 UTC
I know it sounds a silly question, but what do I need to get exactly to get this
problem ?

Comment 3 zingale 2005-07-14 19:23:40 UTC
Sorry for the delay in responding.  Media in OOo 2.0 is handled via the Java
Media framework, http://java.sun.com/products/java-media/jmf/2.1.1/download.html

When this is properly installed, you can play back certain video formats (MPEG-1
seems to work) embedded into the slide.  

These are the steps that I used previously to get movies playing in OOo 1.9.79
and 1.9.104 from the openoffice.org website.  With the Fedora OOo 1.9.104, the
movie played, but it openned its own window in the top left corner of the
screen.  I will test out the lastest Fedora OOo this weekend, to see if things
have changed.

# Install j2re and mozilla-j2re packages. 

# Make sure that java is in your path. In your .cshrc add:
setenv PATH /usr/lib/jre/bin/:$PATH

# Get the Java Media Framework and install it:
sh ./jmf-2_1_1e-linux-i586.bin
chown -R username:username JMF-2.1.1e
initialize things (even though the install script did it as well), by running
$JMFHOME/bin/jmfinit

# setup the JMF environment. Add to you .cshrc
setenv JMFHOME /home/username/JMF-2.1.1e/
setenv CLASSPATH
$JMFHOME/lib/jmf.jar:$JMFHOME/lib/mediaplayer.jar:$JMFHOME/lib/multiplayer.jar
setenv LD_LIBRARY_PATH $JMFHOME/lib:${LD_LIBRARY_PATH}
setenv PATH ${PATH}:$JMFHOME/bin
and then make the changes stick, source .cshrc

# now try running jmstudio in $JMFHOME/bin. This will pop up a little window, go
to the File menu and open an MPEG-1 movie and ensure that it plays.

# Fow what ever reason, things don't seem to respect the CLASSPATH, so copy all
the contents of the JMF lib/ directory into the JRE extension directory (as root):
cp $JMFHOME/lib/* /usr/lib/jre/lib/ext

# Now test things out in Mozilla, to ensure that the JRE sees the JMF stuff. Sun
has a diagnostic page for this. Go to JMF diagnostics and make sure that is says:
JMF Version... 2.1.1e

All Java Build
Native Libraries Found

If you don't see this, then OOo will not work either. Most likely, something was
not copied into the right directory in the step above.

# Get the latest Openoffice.org build, untar and install (skipping the
suse-menus RPM on a Redhat system).

# Launch Openoffice.org,
/opt/openoffice.org1.9.79/program/soffice
Go to Tools/Options/Java/Class Path and add $JMFHOME/lib and exit OOo.

# Now things should all be set. relaunch Openoffice.org and create a
presentation and try embedding movies.

Comment 4 Caolan McNamara 2005-07-14 19:38:45 UTC
I'll have a look, but the only difference between upstream OOo and our one in
tis area is that ours is built/run with gcj/gij so this will likely not be a
specific OOo issue, but rather some gcj thing

Comment 5 Caolan McNamara 2005-07-15 14:17:24 UTC
nah.., there's nothing I can do about this :-( 

Too many sun java components which we don't support involved in the process
which don't work with gcj yet. (caolanm->fitzsim: unless you want to give this a
once over from a gcj perspective...)

e.g. jmstudio with gcj and without sun-java gives..

Exception in thread "main" java.lang.NullPointerException
   at .get_state (/usr/lib/lib-gnu-java-awt-peer-gtk.so.6.0.0)
   at .Java_gnu_java_awt_peer_gtk_GtkMenuPeer_addItem
(/usr/lib/lib-gnu-java-awt-peer-gtk.so.6.0.0)   at
gnu.java.awt.peer.gtk.GtkMenuPeer.addItem(java.awt.peer.MenuItemPeer, int,
boolean) (/usr/lib/lib-gnu-java-awt-peer-gtk.so.6.0.0)
   at gnu.java.awt.peer.gtk.GtkMenuPeer.addItem(java.awt.MenuItem)
(/usr/lib/lib-gnu-java-awt-peer-gtk.so.6.0.0)
   at java.awt.Menu.add(java.awt.MenuItem) (/usr/lib/libgcj.so.6.0.0)
   at JMStudio.createMenu() (Unknown Source)
   at JMStudio.initFrame() (Unknown Source)
   at jmapps.ui.JMFrame.JMFrame(java.awt.Frame, java.lang.String) (Unknown Source)
   at jmapps.ui.PlayerFrame.PlayerFrame(java.awt.Frame, java.lang.String)
(Unknown Source)
   at JMStudio.JMStudio() (Unknown Source)
   at JMStudio.createNewFrame() (Unknown Source)
   at JMStudio.main(java.lang.String[]) (Unknown Source)
   at gnu.java.lang.MainThread.call_main() (/usr/lib/libgcj.so.6.0.0)
   at gnu.java.lang.MainThread.run() (/usr/lib/libgcj.so.6.0.0)

Comment 6 Thomas Fitzsimmons 2005-07-15 14:33:46 UTC
At least this jmstudio error should be easy to fix.  I'll have a look. 
Reopening and reassigning.


Comment 7 Caolan McNamara 2006-01-23 20:52:32 UTC
*** Bug 178727 has been marked as a duplicate of this bug. ***

Comment 8 Thomas Fitzsimmons 2006-02-04 01:38:46 UTC
I can't click through the JMF license.  Is there any way you can reduce this to
a test case so that I don't need to download proprietary software to reproduce it?


Comment 9 Thomas Fitzsimmons 2006-07-26 18:22:28 UTC
Can someone retry this against Rawhide?  At least the null pointer exception
should have been fixed by the libgcj backport.

As for a long-term solution to the JMF problem, there is FMJ:

http://fmj.sourceforge.net/

Maybe someone could try OpenOffice's media support against FMJ.


Comment 10 Caolan McNamara 2006-08-17 09:38:17 UTC
caolanm->fitzsim: Our future plan here from the OOo side is to replace the java
avmedia stuff with a gstreamer implementation http://rodo.foo.cz/blog/?p=16 so
this jmf isn't a priority for me if you'd like to close it out.

Comment 11 Thomas Fitzsimmons 2006-08-17 13:41:42 UTC
Sounds good.  Let's leave this open until the gstreamer implementation hits
Rawhide, that is, until this bug is actually fixed.  Just curious: what's the
timeframe for that?


Comment 12 Caolan McNamara 2006-08-17 13:55:35 UTC
probably FC-7

Comment 13 Thomas Fitzsimmons 2007-01-11 20:27:24 UTC
Caolan, how is this looking for Fedora 7?


Comment 14 Caolan McNamara 2007-01-12 09:29:33 UTC
http://qa.openoffice.org/issues/show_bug.cgi?id=68717 there's a set of patches
in ooo-build but not upstreamed yet, though they look fairly good too me

Comment 15 Red Hat Bugzilla 2007-02-05 19:25:05 UTC
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.

Comment 16 Caolan McNamara 2007-04-17 09:06:17 UTC
if you open http://people.redhat.com/caolanm/slideshow/videodemo.odp with the
current rawhide to-be-FC-7 OOo it should now work and play the video when you go
fullscreen


Note You need to log in before you can comment on or make changes to this bug.