Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161470 - Duplicate "Starting postgresql" at boot
Summary: Duplicate "Starting postgresql" at boot
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: postgresql
Version: rawhide
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Tom Lane
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-23 16:31 UTC by Ian Pilcher
Modified: 2013-07-03 03:06 UTC (History)
3 users (show)

Fixed In Version: 8.1.6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-11 16:43:22 UTC


Attachments (Terms of Use)
Patch to /etc/rc.d/rc to special-case lm_sensors (deleted)
2005-06-23 16:32 UTC, Ian Pilcher
no flags Details | Diff
Make the init.d/functions inclusion detectable by /etc/rc.d/rc (deleted)
2006-11-12 03:09 UTC, Miloslav Trmač
no flags Details | Diff

Description Ian Pilcher 2005-06-23 16:31:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When lm_sensors is enabled ('chkconfig lm_sensors on'), "Starting lm_sensors:"
is printed twice when the system boots:

  Starting lm_sensors: Starting lm_sensors:          [ OK ]

Version-Release number of selected component (if applicable):
initscripts-8.11.1-1

How reproducible:
Always

Steps to Reproduce:
1.  Run /usr/sbin/sensors-detect to configure lm_sensors.
2.  '/sbin/chkconfig lm_sensors on' to enable lm_sensors.
3.  Reboot.
  

Actual Results:  Starting lm_sensors: Starting lm_sensors:            [ OK ]

Expected Results:  Starting lm_sensors:                                 [ OK ]

Additional info:

I'm submitting this as an initscripts bug, since my patch modifies /etc/rc.d/rc.

(BTW, the test at line 87 of /etc/rc.d/rc seems awfully hackish; is there really
not a better way?)

Comment 1 Ian Pilcher 2005-06-23 16:32:31 UTC
Created attachment 115881 [details]
Patch to /etc/rc.d/rc to special-case lm_sensors

Comment 2 Ian Pilcher 2005-06-29 18:58:11 UTC
BTW, PostgreSQL suffers from a similar problem on shutdown.

Comment 3 Adam Pribyl 2005-09-30 18:30:29 UTC
I can confirm this for postfix happening too. It is not high priority but it
also seems easy to fix. (and was not present in FC3) 

This is one of these bugs that do not harm, but are pretty visible for user.

Comment 4 Miloslav Trmač 2006-11-12 02:47:20 UTC
initscripts-8.42 has changed the "native service" detection, which fixes
lm-sensors and postfix.

Reassigning to postgresql.

Comment 5 Miloslav Trmač 2006-11-12 03:09:49 UTC
Created attachment 140979 [details]
Make the init.d/functions inclusion detectable by /etc/rc.d/rc

This patch fixes the problem for postgresql.

Comment 6 Tom Lane 2006-11-12 05:01:57 UTC
Huh?  That patch looks like a complete no-op to me.  What is the underlying problem exactly?

Comment 7 Miloslav Trmač 2006-11-12 05:10:14 UTC
See /etc/rc.d/rc:
        if LC_ALL=C egrep -q "^..*init.d/functions" $i \
                        || [ "$subsys" = "single" -o "$subsys" = "local" ]; then
                $i start
        else
                action $"Starting $subsys: " $i start
        fi

". $INITD/functions" is not matched by the grep, so rc helpfully attempts to
provide the "starting postgresql" message and the "[ OK ]" status indication.

Comment 8 Tom Lane 2006-11-12 05:21:39 UTC
Eeek.  I have to agree with Ian's original comment that there should be a better way.  But at the same time 
there's no particular use in the INITD variable in postgresql.init, so will comply in next turn.

Comment 9 Tom Lane 2007-01-11 16:43:22 UTC
I've modified postgresql.init in the latest packages for FC5 and up.


Note You need to log in before you can comment on or make changes to this bug.