Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161462 - renice does not behave as documented: does not parse POSIX -n option correctly
Summary: renice does not behave as documented: does not parse POSIX -n option correctly
Keywords:
Status: CLOSED DUPLICATE of bug 161321
Alias: None
Product: Fedora
Classification: Fedora
Component: man-pages
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jiri Ryska
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-23 15:59 UTC by Robin Green
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: man-pages-2.05-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-14 08:24:12 UTC


Attachments (Terms of Use)

Description Robin Green 2005-06-23 15:59:10 UTC
Description of problem:
The POSIX man page for renice, i.e. /usr/share/man/man1p/renice.1p.gz
which is from the man-pages package, is displayed when I type "man renice". But
the supplied version of "renice" does not work as documented in the POSIX man
page - it does not parse the -n option.

So, either the POSIX man page should not be displayed when typing "man renice",
or the version of renice supplied should be modified to process the -n option
correctly.

Version-Release number of selected component (if applicable):
util-linux-2.12p-10

How reproducible:
Always

Steps to Reproduce:
1. Substitute a PID of a running process into this command:
renice -n 10 -p 5806
  
Actual results:
renice: 10: getpriority: No such process
5806: old priority 10, new priority 0
(Comment: 10 seems to be interpreted as a PID, not as a renice increment.)

Expected results:
5806: old priority 0, new priority 10

Additional info:
Workaround: omit -n

Comment 1 Robin Green 2005-06-23 16:01:15 UTC
Sorry, the "actual results" should read:

renice: 10: getpriority: No such process
5806: old priority 0, new priority 0

Comment 2 Karel Zak 2005-07-12 09:40:11 UTC
Hmm.. you're right. We have duplicate man page for the renice command:



Comment 3 Karel Zak 2005-07-12 09:45:26 UTC
man 1p renice  <-- wrong, from man-pages package
man 8 renice   <-- correct, from util-linux package

I think the version from man-pages should be removed.

Comment 4 Jiri Ryska 2005-07-14 08:24:12 UTC
The wrong version from man-pages was removed in man-pages-2.05-1. `man renice`
now show correct man page from util-linux package.

*** This bug has been marked as a duplicate of 161321 ***


Note You need to log in before you can comment on or make changes to this bug.