Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161452 - octave-devel is missing dependencies
Summary: octave-devel is missing dependencies
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: octave
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-23 15:29 UTC by Quentin Spencer
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-13 13:22:56 UTC


Attachments (Terms of Use)

Description Quentin Spencer 2005-06-23 15:29:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
I am including a patch here based on my experience packaging octave for Fedora Extras 4. The octave-devel package is missing a dependency on readline-devel and on octave itself. The mkoctfile script in octave-devel will fail without the libraries included in both of these packages.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Remove octave and readline-devel, install octave-devel, and try to compile a file using mkoctfile (some files that can be compiled using mkoctfile can be found in examples/ in the octave source tree).

  

Additional info:

The patch below fixes this bug as well as two other ones:
1. The CFLAGS set in the configure command are useless because octave is written in c++, so it should be CXXFLAGS instead.
2. The libdir needs to be set in the configure command, otherwise mkoctfile looks for things in /usr/lib instead of /usr/lib64 on x86_64.

Patch:
--- octave.spec.~1~     2005-06-23 10:14:08.000000000 -0500
+++ octave.spec 2005-06-23 10:15:27.000000000 -0500
@@ -40,6 +40,7 @@
 %package devel
 Summary: Development headers and files for Octave
 Group: Development/Libraries
+Requires: %{name} = %{epoch}:%{version}-%{release} readline-devel

 %description devel
 The octave-devel package contains files needed for developing
@@ -63,7 +64,7 @@
 %build
 LC_ALL=POSIX
 export LC_ALL
-CFLAGS="$RPM_OPT_FLAGS -fPIC -D_GNU_SOURCE" ./configure --enable-dl --enable-shared=yes --enable-rpath --enable-lite-kernel --enable-picky-flags --enable-static=no --with-g77 --prefix=/usr --infodir=/usr/share/info
+CXXFLAGS="$RPM_OPT_FLAGS -fPIC -D_GNU_SOURCE" ./configure --enable-dl --enable-shared=yes --enable-rpath --enable-lite-kernel --enable-picky-flags --enable-static=no --with-g77 --prefix=/usr --infodir=/usr/share/info --libdir=%{_libdir}

 make

Comment 1 Ivana Varekova 2005-07-13 13:22:56 UTC
Thank you for your notice.
This bug is fixed in fc3 (the last core dist). It is fixed in version 2.1.57-7.fc3.


Note You need to log in before you can comment on or make changes to this bug.