Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161433 - /etc/profile incorrect for ksh as login shell
Summary: /etc/profile incorrect for ksh as login shell
Keywords:
Status: CLOSED DUPLICATE of bug 160731
Alias: None
Product: Fedora
Classification: Fedora
Component: setup
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-23 12:57 UTC by Bert DeKnuydt
Modified: 2014-03-17 02:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-23 16:09:15 UTC


Attachments (Terms of Use)

Description Bert DeKnuydt 2005-06-23 12:57:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:

The following in /etc/profile fails in ksh, because EUID is non-existent.
"/etc/profile[17]: [: argument expected"

if [ $EUID = 0 ]; then
    # do something with the path
fi

In FC3, instead of $EUID was used: `id -u`

The package changelog says that 

* Sat Apr 16 2005 Bill Nottingham <notting@redhat.com> 2.5.41-1
- get rid of 'id' error messages if there is no /usr (#142707)

But replacing it with a bash-ism is no solution either ...

Version-Release number of selected component (if applicable):
setup-2.5.44-1

How reproducible:
Always

Steps to Reproduce:
1.Give a user ksh as login shell
2.Let him login
3.
  

Actual Results:  /etc/profile[17]: [: argument expected

Expected Results:  No errors during login.

Additional info:

Comment 1 Bill Nottingham 2005-06-23 16:09:15 UTC

*** This bug has been marked as a duplicate of 160731 ***


Note You need to log in before you can comment on or make changes to this bug.