Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161424 - Updating selinux-policy-targeted very slow with large nfs mounts
Summary: Updating selinux-policy-targeted very slow with large nfs mounts
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: policycoreutils
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-23 11:06 UTC by Michael Young
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: Latest
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-12-10 18:08:32 UTC


Attachments (Terms of Use)
Patch to stop following nfs partitions (deleted)
2005-09-28 14:42 UTC, Daniel Walsh
no flags Details | Diff

Description Michael Young 2005-06-23 11:06:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7.8) Gecko/20050512 Firefox/1.0.4

Description of problem:
Updating selinux-policy-targeted on a system with large nfs mounts is very slow. This seems to be because the "find" command in the /sbin/fixfiles script can end up traversing the full directory tree of nfs mounts, even though it doesn't print any of the files they contain, and if the nfs file systems are large this can take a very long time. Replacing the find command with 
find $pattern -fstype nfs -prune -o ...
would make things a lot quicker on such systems.

Version-Release number of selected component (if applicable):
policycoreutils-1.18.1-2.12

How reproducible:
Always

Steps to Reproduce:
1. update selinux-policy-targeted on a system with large nfs mounts
  

Additional info:

Comment 1 Daniel Walsh 2005-06-23 15:49:35 UTC
Can you check out the fixfiles from policycoreutils-1.23.18-1
in Rawhide.  Would this satisfy you need?

Dan

Comment 2 Michael Young 2005-06-26 11:43:57 UTC
Do you really mean policycoreutils-1.23.18-1 as I can't find that version anywhere?

Comment 3 Daniel Walsh 2005-06-27 11:00:23 UTC
It is available in Rawhide/FC4

You can also download it (policycoreutils-1.23.18-2) from
ftp://people.redhat.com/dwalsh/SELinux/Fedora

Comment 4 Michael Young 2005-06-27 11:09:03 UTC
The rawhide I can see has policycoreutils-1.23.11-3 . Is this what you mean?

Comment 5 Daniel Walsh 2005-06-27 11:18:52 UTC
Yes, You can look at that one,  I just want you to take a look at fixfiles and
see if that would fix your problem.

Dan

Comment 6 Michael Young 2005-06-27 11:35:13 UTC
No, it doesn't. I should have mentioned that since I submitted the bug I have
seen the problem in FC4 as well. We have an automount at /usr/local and the
sub-mount that contains the fedora patches also contains some unpackaged solaris
patch clusters, which means a lot of files. So the problem occurs when the
script is processing /usr (though /home could potentially cause similar problems
if people are logged on).

Comment 7 Michael Young 2005-09-23 15:51:49 UTC
Changing the version to FC4 as it affects FC4 as well as FC3.

Comment 8 Daniel Walsh 2005-09-27 20:17:18 UTC
Fixed in policycoreutils-1.27.2-1.1

Comment 9 Michael Young 2005-09-28 11:59:01 UTC
No it isn't fixed.

Comment 10 Daniel Walsh 2005-09-28 14:42:19 UTC
Created attachment 119368 [details]
Patch to stop following nfs partitions

Ok I finally got my head out of my but and read the first message again, about
-prune...

How does this patch look to you?

Comment 11 Michael Young 2005-09-28 15:51:24 UTC
Yes, that patch does seem to fix my problem.


Note You need to log in before you can comment on or make changes to this bug.