Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161420 - mptfusion crash during booting
Summary: mptfusion crash during booting
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
: 161347 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-23 08:02 UTC by Fabio Bettoni
Modified: 2015-01-04 22:20 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-03 23:43:08 UTC


Attachments (Terms of Use)
Log of kernel boot (deleted)
2005-06-23 08:02 UTC, Fabio Bettoni
no flags Details

Description Fabio Bettoni 2005-06-23 08:02:03 UTC
Description of problem:


Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1392_FC5
starting from kernel 2.6.12, while kernels 2.6.11 were working

How reproducible:
simply booting


Actual results:
mkrootdev: label /1 not found
Mounting root filesystem
mount: error 2 mounting ext3
Switching to new root
ERROR opening /dev/console!!!!: 2
error dup2'ing fd of 0 to 0
error dup2'ing fd of 0 to 1
error dup2'ing fKernel panic - not syncing: Attempted to kill init!
d of 0 to 2
unmounting old /proc
unmounting ol
Call Trace:
d /sys
switchroot: mo unt failed[<a000000100012160>] show_stack+0x80/0xa0
                                sp=e0000040ffd97c10 bsp=e0000040ffd90fb8
: 22
 [<a000000100012af0>] dump_stack+0x30/0x60
                                sp=e0000040ffd97de0 bsp=e0000040ffd90fa0


Expected results:
booting correctly

Additional info:

Comment 1 Fabio Bettoni 2005-06-23 08:02:03 UTC
Created attachment 115859 [details]
Log of kernel boot

Comment 2 Sammy 2005-06-23 13:08:23 UTC
This is identical to my experience reported in bug #161347 

Comment 3 Fabio Bettoni 2005-06-23 14:00:52 UTC
So it seems an MPT Fusion adapter driver problem, and it's not related to IA64 
architecture.

Comment 4 Tony Luck 2005-06-23 15:01:58 UTC
Try the defconfig or tiger_defconfig that were checked into Linus'
GIT tree yesterday.  They configure MPT Fusion correctly, and boot
for me.

Comment 5 Fabio Bettoni 2005-06-24 12:06:21 UTC
Also kernel-2.6.12-1.1395_FC5 is not working


For Tony: try defconfig or tiger_defconfig means compile vanilla kernel using 
those files as .config ?   How can I get last kernel sources with git ? Thank 
you.


Comment 6 Fabio Bettoni 2005-06-24 12:53:47 UTC
Also kernel-2.6.12-1.1400_FC5.ia64 is not working

Comment 7 Tony Luck 2005-06-24 18:02:20 UTC
"try defconfig or tiger_defconfig" means:

$ cp arch/ia64/defconfig .config
$ make oldconfig
$ make

(or use arch/ia64/configs/tiger_defconfig).

"How can I get last kernel sources with git?" ... if you want to delay learning 
git until it stabilizes, then you can just wait a day and any new code in 
Linus' GIT tree will be conveniently snap-shotted as a daily diff.  See 
the "snapshot" link on the front page of www.kernel.org.

If you are brave and want to try GIT ... which appears to be more than just a 
temporary thing ... then look for one of the recent "how-to" postings on LKML 
(e.g. search for "Updated git HOWTO for kernel hackers").


Comment 8 Fabio Bettoni 2005-06-27 12:45:52 UTC
Vanilla 2.6.12.1 compiles and runs correctly with:
CONFIG_FUSION=m
CONFIG_FUSION_MAX_SGE=40
# CONFIG_FUSION_CTL is not set
# CONFIG_FUSION_LAN is not set

Anyway to have fusion disks as sda,sdb
and sym53c8xx disks as sdc,sdd,sde,sdf
I had to change modprobe.conf to this:
 alias scsi_hostadapter mptbase
 alias scsi_hostadapter1 mptscsih
 alias scsi_hostadapter2 sym53c8xx





Comment 9 Dave Jones 2005-07-08 00:26:34 UTC
*** Bug 161347 has been marked as a duplicate of this bug. ***

Comment 10 Dave Jones 2005-07-08 22:43:05 UTC
Note that rawhide is based on 2.6.13rc trees right now (The version number in
the kernel filename ie kernel-2.6.12-1.1400_FC5 doesn't get bumped until /after/
the release of a new upstream revision).

2.6.12.1 may work, but changes may have occured in 2.6.13rc that have caused
this driver to regress.  You may want to test the latest upstream (currently
2.6.13rc2) and if that is similarly broken, report your findings to
linux-scsi@vger.kernel.org

Thanks.

Comment 11 Miles Sabin 2005-07-29 19:53:26 UTC
Same results for me running rawhide under vmware (the Fusion MPT driver is
selected for vmware SCSI disks) on all kernels I've tried from 2.6.12-1.1434_FC5
up to and including 1441. Last working kernel I have for this VM is
2.6.11-1.1383_FC5.

Comment 12 Sammy 2005-08-15 16:21:22 UTC
This is still causing PANIC with kernel-smp-2.6.12-1.1485_FC5. Not good. Hope 2.6.13 final 
will have a fix. 

Comment 13 Sammy 2005-08-18 14:26:39 UTC
SOLVED: The problem seems to be due to splitting of the mpt modules. I am not sure this is 
                a bug or a feature. I have solved the problem by including "mptspi" module in the 
                initrd image. /etc/modprobe.conf reads: 
 
alias scsi_hostadapter mptbase 
alias scsi_hostadapter1 mptscsih 
alias scsi_hostadapter1 mptspi 
install  mptscsih /sbin/modprobe --ignore-install mptscsih 
install  mptspi /sbin/modprobe --ignore-install mptspi 
 
                  with 2.6.12.x I did not need the two lines containing mptspi. If I do an lsmod I 
                  see that mptscsih module is now used by mptspi. 
 
                  I have a LSI U320 card with two processors. It seems like this should go into 
                  where module changes are handled under FC5. 

Comment 14 Miles Sabin 2005-08-20 14:40:56 UTC
The solution in comment #13 fixes the problem (still present with
2.6.12-1.1502_FC5) under vmware.

Comment 15 Denis Leroy 2005-10-03 22:23:54 UTC
Fantastic. Yes, the solution in comment #13 also fixes the problem when booting
on a Sun V20Z (dual Opteron, LSI 53c1030 Fusion-MPT SCSI). Basically, this bug
affects all systems trying to boot from a SCSI disk requiring the MPT Fusion
driver. It also fixed the boot with VMWare 5.5.0 RC1.


Comment 16 Denis Leroy 2005-10-03 22:39:25 UTC
Just an extra note:

This problem still exists with kernel 2.6.13-1.1589_FC5

The problem lies in the fact that the mptspi module is required, and yet not
loaded automatically when doing 'modprobe mptscsih', which is why mkinitrd
doesn't see the dependency and omits mptspi from the initrd file.


Comment 17 Dave Jones 2005-10-03 23:43:08 UTC
the fc5 installer/kudzu have been changed to create correct modprobe.conf's for
the split up modules. FC5 should work out of the box.

If this isn't the case with the latest rawhide builds (you can test installs
with the boot.iso), please file an anaconda bug


Comment 18 Denis Leroy 2005-10-05 21:06:19 UTC
I'm more concerned about people trying to upgrade from FC4 to FC5. I'll give
that a shot and file an anaconda bug if necessary.


Comment 19 Dave Jones 2005-10-05 22:21:08 UTC
the installer should rewrite /etc/modprobe.conf on an upgrade, so this should be
fine.


Comment 20 Alex Kiernan 2005-10-06 06:23:55 UTC
Anyone who has an up to date FC4 install has already gotten bitten by this 
problem (I did...) - 2.6.13-1.1526_FC4 needs modprobe.conf changing to 
reference mptspi.

Comment 21 Dave Jones 2005-10-06 06:38:47 UTC
FC4 has been dealt with in bug 169610 




Note You need to log in before you can comment on or make changes to this bug.