Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161412 - Fatal Error when installing ntfs module
Summary: Fatal Error when installing ntfs module
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-23 06:25 UTC by Ryan White
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-25 01:49:21 UTC


Attachments (Terms of Use)

Description Ryan White 2005-06-23 06:25:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I just installed FC4 on an AMD64 system. I have a dual boot system, with XP, and another hard drive with mp3 on it, that is formatted as NTFS. It appears that FC4 doesn't come with NTFS support. When I do the mount command, I get this error:
[root@localhost etc]# mount -t ntfs /dev/hdb1 /home/windows
mount: unknown filesystem type 'ntfs'

I downloaded the rpm from sourceforge.net: kernel-module-ntfs-2.6.11-1.1366_FC4-2.1.22-0.rr.6.0.x86_64.rpm
I install it by:
[root@localhost installers]# rpm -ivh kernel-module-ntfs-2.6.11-1.1366_FC4-2.1.22-0.rr.6.0.x86_64.rpm
Preparing... ########################################### [100%]
package kernel-module-ntfs-2.6.11-1.1366_FC4-2.1.22-0.rr.6.0 is already installed

Then I try to load it:
[root@localhost installers]# modprobe ntfs
FATAL: Error inserting ntfs (/lib/modules/2.6.11-1.1369_FC4/kernel/fs/ntfs/ntfs.ko): Invalid module format

I am not sure what this FATAL error means and how to fix it. Any help?

Version-Release number of selected component (if applicable):
kernel-module-ntfs-2.6.11-1.1366_FC4-2.1.22-0.rr.6.0.x86_64.rpm

How reproducible:
Always

Steps to Reproduce:
1. download the appropriate RPM (listed above)
2. install it using "rpm -ivh <rpm>"
3. use 'modprobe ntfs' to try to install the module.
  

Actual Results:  The result is this error:

[root@localhost installers]# modprobe ntfs
FATAL: Module ntfs not found.


Expected Results:  It should have been installed as a loaded module so I can mount NTFS partitions.

Additional info:

Comment 1 Ryan White 2005-06-23 06:26:12 UTC
Above it says "rpm package already installed".  THis is just because I repeated
the steps.  It wasn't originally installed.

Comment 2 Dave Jones 2005-06-25 01:49:21 UTC
report problems with this module to the upstream packagers where you downloaded it.


Note You need to log in before you can comment on or make changes to this bug.