Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161394 - Diskless client panics on boot
Summary: Diskless client panics on boot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-netboot
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 156323
TreeView+ depends on / blocked
 
Reported: 2005-06-22 20:31 UTC by David Milburn
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: RHBA-2005-484
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-05 13:47:53 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:484 qe-ready SHIPPED_LIVE Updated system-config-netboot package 2005-10-05 04:00:00 UTC

Description David Milburn 2005-06-22 20:31:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
The initrd.img created by system-config-netboot is missing
libraries needed to boot the client system.

Version-Release number of selected component (if applicable):
system-config-netboot-0.1.8-1

How reproducible:
Always

Steps to Reproduce:
1. rsync the root directory ("/") of an RHEL 4 system to an RHEL 4
server and configured a diskless service using system-config-netboot 
as described at the manual URL below:

http://www.redhat.com/docs/manuals/enterprise/RHEL- 4-Manual/sysadmin-guide/ch-diskless.html

2. Boot client system.
3.
  

Actual Results:  Diskless systems do not start due to kernel panic.
"Kernel Panic - not syncing : No init found. Try passing init = option 
to kernel. "

Expected Results:  Client should boot successfully.

Additional info:

RH support has verified that system-config-netboot-0.1.20-1 fixes problem.

Comment 1 Michael 2005-06-28 05:28:30 UTC
I am having the same problem on Fedora Core 4. 

Fedora Core 4 ships with system-config-netboot-0.1.14-1

Parameters *are* being passed to the kernel. I verified this by modifying the
'append' arguments in pxelinux.cfg/<client_ip_address>

I then found this bug report and upgraded to system-config-netboot-0.1.20-1

Unfortunately, that did not resolve my problem ... I still see the same behavior
on FC4. 

Q: What can I do to help get this issue resolved? 

Q: Any workarounds? 

Michael



Comment 2 Michael 2005-06-28 10:50:36 UTC
On FC4 ...
I read other/previous bugs related to system-config-netboot. 
I deleted from the previous system-config-netboot installation and started from
scratch. 
Now initrd seems to be OK. Kernel starts the boot process. Dies in NFS, but that
is probably my problem. Will advise. 

Comment 3 Jason Vas Dias 2005-07-05 15:08:14 UTC
Yes, the initrd.img bad libraries issue is definitely fixed with
system-config-netboot-0.1.16+ . The latest s-c-nb version can be
downloaded from:
 http://people.redhat.com/~jvdias/system-config-netboot/ .
The system-config-netboot-0.1.20-1.noarch.rpm package should work
fine on FC-3, FC-4, and RHEL-4 - I'll be issuing FC-3 and FC-4 updates
for it shortly.

How does the boot process "die in NFS"? 
I use these /etc/exports statements with no problems:
"
/client_root_dir/root *(ro,sync,no_root_squash,no_subtree_check)
/client_root_dir/snapshot *(rw,sync,no_root_squash,no_subtree_check)
"
Is the problem reproducable with these options on your NFS server ?

What does the /tftpboot/linux-install/pxelinux.cfg/* configuration
file for your subnet say ?

If you cannot determine the cause of your nfs boot problem, please
attach the output of a serial console boot to this bug report - 
1. edit the /tftpboot/.../pxelinux.cfg/${subnet} configuration file 
   to say:
"label ...
 kernel ...
 append ... console=/dev/ttyS0,9600 console=/dev/console
"
2. Attach a null modem cable to the client and another machine; on
 the other machine, do:
 # tee /tmp/netboot.log < /dev/ttyS0
 and then boot the client.
 When the problem has been reproduced, press CTRL-C and attach the
 /tmp/netboot.log file to this bug report.
Thank you! 


Comment 4 Michael 2005-07-05 22:14:55 UTC
Sorry I did not follow up. I am up and running fine now. 

As I recall, some of my NFS problems were related to confusion caused by bugs in
the system-config-netboot UI. I filed a separate bug report which is also
assigned to Jason Vas Dias ... #   161904  

Comment 9 Accelerated Fix Request (Red Hat Internal App) 2005-07-06 19:40:41 UTC
From User-Agent: XML-RPC

HOTFIX Request has been released http://seg.rdu.redhat.com/scripts/hotfix/edit.pl?id=387

Comment 13 Red Hat Bugzilla 2005-10-05 13:47:54 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-484.html



Note You need to log in before you can comment on or make changes to this bug.