Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161349 - xorg-x11: unpacking of archive failed on file /etc/X11/xkb: cpio: rename
Summary: xorg-x11: unpacking of archive failed on file /etc/X11/xkb: cpio: rename
Keywords:
Status: CLOSED DUPLICATE of bug 107383
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-22 16:08 UTC by Mark Lane
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-30 07:57:02 UTC


Attachments (Terms of Use)

Description Mark Lane 2005-06-22 16:08:52 UTC
Description of problem:
xorg-x11: unpacking of archive failed on file /etc/X11/xkb: cpio: rename

Version-Release number of selected component (if applicable):
xorg-x11.x86_64 0:6.8.2-37

How reproducible:
Every time

Steps to Reproduce:
1. Attempt to add this update package with yum
Or
1. Attempt to add package with rpm -Uvh
  
Actual results:
cpio error

Expected results:


Additional info:

Comment 1 Mark Lane 2005-06-22 16:14:57 UTC
I downloaded the package from the official fedora site and same problem.

Comment 2 Mark Lane 2005-06-22 16:27:55 UTC
Following Michal's suggestion, I removed the /etc/X11/xkb directory and the
package installed. Note my machine was an upgrade and I upgraded it by using yum
upgrade.

Comment 3 Mike A. Harris 2005-06-22 19:25:05 UTC
The error you've received indicates that "/etc/X11/xkb" is a directory on
your system instead of a symlink.  This will be the case if you download
Xorg or XFree86 source code, compile it yourself and install it on top of
the Red Hat rpm provided X.

In our packaging "/etc/X11/xkb" is a symbolic link.  When you try to upgrade
our rpm packaged X on top of a custom build of X from source, or from 3rd
party rpms that make /etc/X11/xkb a directory, rpm is unable to replace a
directory with a symlink, and you will receive this error and be unable
to proceed.

Upgrading over top of 3rd party software installed outside of the context
of rpm is not supported and not expected to work properly, in particular
for situations where there is a directory/symlink reversal.  For additional
detailed information on the rpm directory/symlink limitation, you may find
bug #107383 helpful.  

If you do a clean installation of Fedora Core 4 from scratch (on any
system), without installing any 3rd party X installation, and then
upgrading to the 6.8.2-37 release, this problem should not be
reproduceable.

Please confirm that a clean install and upgrade to the current xorg-x11
rpm works as expected.

Setting status to "NEEDINFO".


Comment 4 Mike A. Harris 2005-08-30 07:57:02 UTC
There hasn't been any response to my above inquiry, so I'm assuming
that my prognosis was correct about the /etc/X11/xkb symlink/dir
issue.

Closing bug as duplicate of master tracker.




*** This bug has been marked as a duplicate of 107383 ***


Note You need to log in before you can comment on or make changes to this bug.