Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161321 - renice man page gives incorrect usage instruction
Summary: renice man page gives incorrect usage instruction
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: man-pages
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jiri Ryska
QA Contact: Ben Levenson
URL:
Whiteboard:
: 161462 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-22 13:01 UTC by Charles R. Price, Jr.
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: man-pages-2.05-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-04 14:56:30 UTC


Attachments (Terms of Use)

Description Charles R. Price, Jr. 2005-06-22 13:01:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
The renice man page installed at /usr/share/man/man1p/renice.1p.gz calls for a
-n parameter as follows:
renice -n increment [-g | -p | -u] ID ...

This differs from, and precedes in search order, the util-linux-2.12p man page at /usr/share/man/man8/renice.8.gz which gives the following synopsis:
renice priority [[-p] pid ...] [[-g] pgrp ...] [[-u] user ...]

The major difference is the -n parameter called for in the man-pages instruction, but not accepted by the util-linux program.

If the -n parameter is used the following error message is returned:

renice: 10: getpriority: No such process
3983: old priority 0, new priority 0


Version-Release number of selected component (if applicable):
man-pages-1.67-7

How reproducible:
Always

Steps to Reproduce:
1.renice -n 10 -p <pid>
2.
3.
  

Actual Results:  renice: 10: getpriority: No such process
3983: old priority 0, new priority 0


Expected Results:  3983: old priority 0, new priority 10

Additional info:

Comment 1 Jiri Ryska 2005-07-14 08:24:14 UTC
*** Bug 161462 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.