Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161316 - arpwatch doesn't run
Summary: arpwatch doesn't run
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
: 163802 165943 175481 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-22 11:35 UTC by Trond Eivind Glomsrød
Modified: 2014-03-17 02:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-23 17:24:19 UTC


Attachments (Terms of Use)
supposed patch (deleted)
2005-06-23 12:13 UTC, Martin Stransky
no flags Details

Description Trond Eivind Glomsrød 2005-06-22 11:35:29 UTC
Description of problem:

"service arpwatch" fails.

Version-Release number of selected component (if applicable):

tcpdump-3.8.2-13.FC4


Additional info:

The bug is in how the initscripts handles quoted information vs. how arpwatch
does it in /etc/sysconfig/arpwatch . Avoiding quoting information with the -s
option makes it work, looking at "bash -x /etc/init.d/arpwatch start" shows
oddities.

Comment 1 Martin Stransky 2005-06-23 12:13:53 UTC
Created attachment 115866 [details]
supposed patch

Comment 2 Bill Nottingham 2005-06-23 17:24:19 UTC
Added in CVS, will be in 8.12. Still seems like a hack, though.

Comment 3 Martin Stransky 2005-07-21 09:51:44 UTC
*** Bug 163802 has been marked as a duplicate of this bug. ***

Comment 4 Doug Kennedy 2005-08-15 15:41:39 UTC
*** Bug 165943 has been marked as a duplicate of this bug. ***

Comment 5 Bill Nottingham 2005-12-12 19:04:44 UTC
*** Bug 175481 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.