Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161313 - oowriter crashes when attempting to delete a frame from a .rtf document
Summary: oowriter crashes when attempting to delete a frame from a .rtf document
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-22 11:07 UTC by Christer Nyfält
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 1.9.121-3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-28 09:07:03 UTC


Attachments (Terms of Use)
Zipped .rtf file with embedded picture (deleted)
2005-06-22 11:52 UTC, Christer Nyfält
no flags Details


Links
System ID Priority Status Summary Last Updated
OpenOffice.org 52542 None None None Never

Description Christer Nyfält 2005-06-22 11:07:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When I from an .rtf document am trying to delete a picture whose placement has become screwed up, I encounter the following problem: The deletion of the picture works, but the program crashes when I try to delete its frame.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open an old .rtf document with a picture in oowriter.
2. Notice that the picture placement is screwed up and delete it.
3. Notice that there is a frame where the picture should have been.
4. Try to delete the frame.

  

Actual Results:  oowriter crashes. If I run oowriter from an terminal window the following is shown:
sh: crash_report: command not found


Expected Results:  Only the frame should have dissappeared, not the whole application.

Additional info:

Comment 1 Caolan McNamara 2005-06-22 11:31:31 UTC
you'll have to attach a sample document which reproduces this.

Comment 2 Christer Nyfält 2005-06-22 11:52:12 UTC
Created attachment 115807 [details]
Zipped .rtf file with embedded picture

Requested document.

Comment 3 Christer Nyfält 2005-06-30 05:19:13 UTC
Change in the bug behavior in the latest update (Ooffice 1:1.9.112-1.1.0.fc4):
- The bug freezes oowriter instead of crashing it.


Comment 4 Caolan McNamara 2005-07-04 08:13:46 UTC
hmm, I've just tried with 1.9.113 (rawhide), and there's now no crash/hang when
I delete the frame. Can you give that a go and confirm that that is the case ?
If so I can make an update for fc4 with that release.

Comment 5 Christer Nyfält 2005-07-04 09:21:01 UTC
I can't install the new version form rawhide, sorry. 
It is beyond my sysadmin skills to do a partial upgrade with a lot of
interdepending packages and I'm not going to upgrade my whole system to rawhide.


Comment 6 Caolan McNamara 2005-07-04 09:37:14 UTC
no problem, I think this is fixed in >= 1.9.113, there'll be an fc4 update in a
few days to verify that this is the case.

Comment 7 Christer Nyfält 2005-07-21 21:08:51 UTC
The bug is still there and crashes oowriter in 1.9.117-3.1.0.fc4.

I get the following dump now:
0x87ab96: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1db96
0x87b3e4: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e3e4
0xc9b420:  + 0x420 (__kernel_sigreturn + 0x0)
0xb4ec435c: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x21035c
0xb4dec8f0: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1388f0
0xb4e13c37: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x15fc37
0xb50349eb: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x3809eb
0xb4ea8edf: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1f4edf
0xb4ea9606: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1f5606
0xb4ea9698: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1f5698
0xb4eaae57: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1f6e57
0xb4eab090: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1f7090
0xb4fd8f6f: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x324f6f
0xb4fc1edb: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x30dedb
0xb4ecf07c: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x21b07c
0xb4e614cb: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1ad4cb
(SwFEShell::DelSelectedObj() + 0x31)
0xb5354ed8: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x6a0ed8
(SwWrtShell::DelRight(unsigned char) + 0x246)
0xb52aed99: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x5fad99
0xb52aee16: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x5fae16
0x19660da: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1960da
0x19654c7: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1954c7
0x19659b8: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1959b8
(SfxDispatcher::_Execute(SfxShell&, SfxSlot const&, SfxRequest&, unsigned short)
+ 0x138)
0x196ebc7: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x19ebc7
0x195d464: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x18d464
0x195d885: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x18d885
0x3a9960: /usr/lib/openoffice.org2.0/program/libsvt680li.so + 0xd0960
0x3a9a22: /usr/lib/openoffice.org2.0/program/libsvt680li.so + 0xd0a22
0x6713c2: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x7a3c2
0x80a7ba: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x2137ba
0x80a7a0: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x2137a0
0x6713c2: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x7a3c2
0x7c5b6f: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1ceb6f
0x6d61e40: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x1ee40
0x6d870d7: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x440d7
(SalDisplay::DispatchInternalEvent() + 0xad)
0x1eac90f: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xa90f
0x44cc650: /usr/lib/libglib-2.0.so.0 + 0x25650
0x44ca3ee: /usr/lib/libglib-2.0.so.0 + 0x233ee (g_main_context_dispatch + 0x1dc)
0x44cd3f6: /usr/lib/libglib-2.0.so.0 + 0x263f6
0x44cd8d8: /usr/lib/libglib-2.0.so.0 + 0x268d8 (g_main_context_iteration + 0x66)
0x1eac535: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xa535
0x6d88da1: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x45da1
(X11SalInstance::Yield(unsigned char) + 0x29)
0x67773c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8073c
(Application::Yield() + 0x50)
0x67777a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8077a
(Application::Execute() + 0x26)
0x8065670: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x1d670
(desktop::Desktop::Main() + 0x149a)
0x67cb69: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x85b69 (SVMain()
+ 0x45)
0x8060723: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x18723 (sal_main +
0x47)
0x25e0de6: /lib/libc.so.6 + 0x14de6 (__libc_start_main + 0xc6)
0x8060659: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x18659
(Window::RequestHelp(HelpEvent const&) + 0x31)


Comment 8 Caolan McNamara 2005-07-22 07:51:37 UTC
I see, when I delete the frame there is no crash, but if I delete the graphic
and *then* the frame I can reproduce this.

Comment 9 Caolan McNamara 2005-07-27 10:35:55 UTC
have a workaround

Comment 10 Christer Nyfält 2005-08-27 15:11:07 UTC
I confirm that the bug is fixed in 1.9.125-1.1.0.fc4.
The frame is now deleted at the same time as picture with no crashes.
Good.
The resolution field should probably be changed from RAWHIDE to something else
(ERRATA?) now that it is fixed in an undate. 


Note You need to log in before you can comment on or make changes to this bug.