Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161306 - grub does not work well with reiserfs
Summary: grub does not work well with reiserfs
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: grub
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-22 10:03 UTC by Steven Shiau
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-06 21:10:41 UTC


Attachments (Terms of Use)

Description Steven Shiau 2005-06-22 10:03:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041009 Firefox/1.0

Description of problem:
I just installed Fedora Core 4, and put /boot directory in reiserfs 3.6 partition with the other root files in /dev/hda1. After installation, the next boot will be in grub shell, i.e. grub can not find /boot/grub/menu.lst in this reiserfs partition /dev/hda1. I am sure /boot/grub/menu.lst does exist.
After many rebooting, it still the same.

My solution: 
1. Use Knopix or other rescue method to boot ( I use Fedora Core 3 diskless solution - DRBL (drbl.sf.net)).
2. mount /dev/hda1 /mnt
3. grub-install --root-directory=/mnt /dev/hda

The grub I used is from FC3, i.e. grub-0.95-3.

Then it works.


Version-Release number of selected component (if applicable):
grub-0.95-13, kernel-2.6.11-1.1369_FC4, reiserfs 3.6

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora Core 4, when in disk 1, in the prompt, enter "linux reiserfs"
2. When creating partition, format the root directory as reiserfs, and remember to put /boot in the same partition with root partition.
3. Finish the installation.

  

Actual Results:  After the installation, boot FC4, then it will in grub-shell.

Expected Results:  Boot into FC4 successfully.

Additional info:

My solution: 
1. Use Knopix or other rescue method to boot ( I use Fedora Core 3 diskless solution - DRBL (drbl.sf.net)).
2. mount /dev/hda1 /mnt
3. grub-install --root-directory=/mnt /dev/hda

The grub I used is from FC3, i.e. grub-0.95-3.

Comment 1 Peter Jones 2005-07-06 21:10:41 UTC
reiserfs is completely unsupported.

Comment 2 Steven Shiau 2005-07-06 23:12:50 UTC
(In reply to comment #1)
> reiserfs is completely unsupported.

Well, that's true in RH/Fedora. But grub does support reiserfs. This is a bug
report for grub also. Maybe in the next version, please make it work as before.
Thanks.

Comment 3 Russell Coker 2005-07-19 07:15:57 UTC
I've just tested this out.  I've had the root LV on ReiserFS with /boot on 
Ext3 and having both /boot and the root LV on ReiserFS.  In both cases it 
works, I can't reproduce the problem. 
 
Can you reproduce this with "selinux=0" included on the kernel command-line 
for the install?  There are known issues with SE Linux and ReiserFS. 

Comment 4 Steven Shiau 2005-07-19 08:18:22 UTC
In my FC4 machine, I did turn of selinux all the time.
--------
cat /etc/selinux/config
# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
#       enforcing - SELinux security policy is enforced.
#       permissive - SELinux prints warnings instead of enforcing.
#       disabled - SELinux is fully disabled.
SELINUX=disabled
# SELINUXTYPE= type of policy in use. Possible values are:
#       targeted - Only targeted network daemons are protected.
#       strict - Full SELinux protection.
SELINUXTYPE=targeted
----------
I have a SATA IDE HD
----------
ata1: SATA max UDMA/133 cmd 0xEFA8 ctl 0xEFA6 bmdma 0xEED0 irq 169
ata2: SATA max UDMA/133 cmd 0xEF68 ctl 0xEFA2 bmdma 0xEED8 irq 169
ata1: dev 0 cfg 49:2f00 82:74eb 83:7fea 84:4023 85:74e9 86:3c02 87:4023 88:203f
ata1: dev 0 ATA, max UDMA/100, 321672960 sectors: lba48
ata1: dev 0 configured for UDMA/100
scsi0 : ata_piix
ata2: SATA port has no device.
scsi1 : ata_piix
  Vendor: ATA       Model: HDS722516VLSA80   Rev: V34O
  Type:   Direct-Access                      ANSI SCSI revision: 05
SCSI device sda: 321672960 512-byte hdwr sectors (164697 MB)
SCSI device sda: drive cache: write back
SCSI device sda: 321672960 512-byte hdwr sectors (164697 MB)
---------
I put all my partitions as reiserfs, and without extra /boot partition.
---------
df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda2             9.4G  3.7G  5.7G  39% /
/dev/shm             1009M     0 1009M   0% /dev/shm
/dev/sda6             133G  121G   13G  91% /home
---------
In the previous post, I put the wrong device (/dev/hda), actually it should be
/dev/sda.
Maybe my problem is because there is no extra /boot partition for grub-0.95-13 ?


Note You need to log in before you can comment on or make changes to this bug.