Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161302 - wrong entry for swap in /etc/fstab
Summary: wrong entry for swap in /etc/fstab
Keywords:
Status: CLOSED DUPLICATE of bug 159087
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-22 08:16 UTC by Gezim Hoxha
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-22 14:02:10 UTC


Attachments (Terms of Use)

Description Gezim Hoxha 2005-06-22 08:16:41 UTC
Description of problem:
Entry for swap partition in /etc/fstab is garbage. And when computer boots, I
get I (something like). I have a 60GB HD at 7200RPM. I have 3.4GHz processor
with HT.
"mounting other filesystems: mount: no mount point );"
[root@localhost ~]# more /etc/fstab
LABEL=/                 /                       ext3    defaults        1 1
/dev/devpts             /dev/pts                devpts  gid=5,mode=620  0 0
/dev/shm                /dev/shm                tmpfs   defaults        0 0
/dev/proc               /proc                   proc    defaults        0 0
/dev/sys                /sys                    sysfs   defaults        0 0
LABEL=tyle );
                                sH   swap                    swap    defaults
     0 0
[root@localhost ~]#


Here are my partitoins:
[root@localhost ~]# fdisk -l

Disk /dev/hda: 60.0 GB, 60011642880 bytes
255 heads, 63 sectors/track, 7296 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1               1          62      497983+  83  Linux
/dev/hda2              63         185      987997+  82  Linux swap / Solaris
/dev/hda3   *         186         794     4891792+   b  W95 FAT32
/dev/hda4             795        7296    52227315    f  W95 Ext'd (LBA)
/dev/hda5             795        3834    24418768+  83  Linux
/dev/hda6            3835        5659    14659281   83  Linux
/dev/hda7            6445        7296     6843690   83  Linux
[root@localhost ~]#

How reproducible:
I installed FC4 three times and same thing.

Steps to Reproduce:
1.No idea if I have special hardware that's causing this or what.
  
Actual results:
[root@localhost ~]# more /etc/fstab
LABEL=/                 /                       ext3    defaults        1 1
/dev/devpts             /dev/pts                devpts  gid=5,mode=620  0 0
/dev/shm                /dev/shm                tmpfs   defaults        0 0
/dev/proc               /proc                   proc    defaults        0 0
/dev/sys                /sys                    sysfs   defaults        0 0
LABEL=tyle );
                                sH   swap                    swap    defaults
     0 0
[root@localhost ~]#

Expected results:
Maybe:
LABEL=/                 /                       ext3    defaults        1 1
/dev/devpts             /dev/pts                devpts  gid=5,mode=620  0 0
/dev/shm                /dev/shm                tmpfs   defaults        0 0
/dev/proc               /proc                   proc    defaults        0 0
/dev/sys                /sys                    sysfs   defaults        0 0
/dev/hda2               none                    swap    defaults        0 0

Additional info:
anaconda-ks.cfg:
[root@localhost ~]# more anaconda-ks.cfg
# Kickstart file automatically generated by anaconda.

install
cdrom
lang en_US.UTF-8
langsupport --default=en_US.UTF-8 en_US.UTF-8 en_US en en_US.UTF-8 en_US en
keyboard us
xconfig --card "ATI Radeon Mobility 9600 M10" --videoram 131008 --hsync
31.5-37.9 --vsync 50-70 --resolution 800x600 --depth 16 --startxonboot 
--defaultdesktop gnome
network --device eth0 --bootproto dhcp
rootpw --iscrypted [removed by me]
firewall --enabled
selinux --permissive
authconfig --enableshadow --enablemd5
timezone America/Edmonton
bootloader --location=mbr --driveorder=hda --append="rhgb quiet"
# The following is the partition information you requested
# Note that any partitions you deleted are not expressed
# here so unless you clear all partitions first, this is
# not guaranteed to work
#clearpart --linux
#part / --fstype ext3 --onpart hda7
#part swap --onpart hda2

%packages
@ office
@ editors
@ text-internet
@ gnome-desktop
@ dialup
@ base-x
@ graphics
@ printing
@ admin-tools
@ development-tools
@ sound-and-video
@ graphical-internet
pcmcia-cs
kernel-smp-devel
kernel-smp
grub
e2fsprogs

%post
[root@localhost ~]#

Comment 1 Chris Lumens 2005-06-22 14:02:10 UTC

*** This bug has been marked as a duplicate of 159087 ***


Note You need to log in before you can comment on or make changes to this bug.