Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161295 - portmapper prevents unprivileged port access for rstatd
Summary: portmapper prevents unprivileged port access for rstatd
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: portmap
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-22 03:32 UTC by Anthony Thyssen
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-12-07 01:54:01 UTC


Attachments (Terms of Use)

Description Anthony Thyssen 2005-06-22 03:32:24 UTC
+++ This bug was initially created as a clone of Bug #155940 +++

Description of problem:

This is the same problem as Bug #155940, but from a different client.

portmap was compiled with -DCHECK_PORT, which prevents it accepting any request
for an RPC service from a non-priviliaged port.

However rstatd clients, such as rup, and xmeter to name common ones are user
informational programs which do not need or want root access to create a
privaliged port.  As such portmap denies ALL requests for rstatd load and uptime
information from these and other load/uptime monitoring clients!

In other words because of this compile time option, rstatd is USELESS!!!
Any attemt to access rstatd is logged with...
     portmap[4431]: connect from 127.0.0.1 to unset(rstatd): request from
unprivileged port

Version-Release number of selected component (if applicable):
portmap-4.0-65
rusers-server-0.17-43
rusers-0.17-43

How reproducible:
Everytime.
   portmap runs by default
   start the rstatd, make sure  rpc.statd is running
   add portmap access to hosts.allow
   try      rup localhost
      rup: localhost: RPC: Unable to receive; errno = Connection refused
   /var/log/messages shows rejection of connection by portmap


Note You need to log in before you can comment on or make changes to this bug.