Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161290 - Suggest replace gEdit with Leafpad
Summary: Suggest replace gEdit with Leafpad
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gedit
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-22 02:43 UTC by Jones Lee
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-22 03:38:24 UTC


Attachments (Terms of Use)

Description Jones Lee 2005-06-22 02:43:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Maxthon; .NET CLR 1.1.4322)

Description of problem:
Standing on the user's view, I reckon we shold replace gEdit with Leafpad due to some reasons:
 + gEdit is not a simple text editor anymore, we should depracate them from the main stream. We know that gEdit is growing to be a very good programming text editor, even better than Anjuta. We should free gEdit from its curse as "simple text editor". My suggestion is to include gEdit as extra or in programming section.
 + Leafpad is 2x faster, smaller in size, efficient, simple like Windows's Notepad. It doesn't require many GNOME dependencies. People use Notepad on Windows always keep in mind that they're doing some simple draft text, for a full document editing, they will use MS Office or OOo.

Please vote for this.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Nothing

Additional info:

Comment 1 Ray Strode [halfline] 2005-06-22 03:38:24 UTC
Hi Jones,

GEdit is very fast, simple, and has active upstream developers.  It's all around
very good.  It's also the default text editor for upstream gnome.  I don't see
the point of changing it.  

If upstream changes their default, Fedora Core will probably change too, of course.




Note You need to log in before you can comment on or make changes to this bug.