Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161282 - package needs dependency on lynx
Summary: package needs dependency on lynx
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: jwhois
Version: 4
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-22 00:14 UTC by Andreas Kupfer
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-03 19:41:52 UTC


Attachments (Terms of Use)

Description Andreas Kupfer 2005-06-22 00:14:24 UTC
From Bugzilla Helper:
User-Agent: Opera/8.01 (X11; Linux i686; U; en)

Description of problem:
The lookup of .de doesn't work, because lynx is not installed.

[kupfer@antwort ~]$ whois 42h.de
[Querying http://www.denic.de/en/whois/data.jsp]
[kupfer@antwort ~]$

[kupfer@antwort ~]$ whois -vv 42h.de
[Debug: Cache = On]
[Debug: Force lookup = No]
[Debug: Force host = (None)]
[Debug: Force port = (None)]
[Debug: Config file name = /etc/jwhois.conf]
[Debug: Follow redirections = Yes]
[Debug: Display redirections = No]
[Debug: Whois-servers.net service support = Yes]
[Debug: Whois-servers domain = whois-servers.net]
[Debug: Raw query = No]
[Debug: Rwhois display = (None)]
[Debug: Rwhois limit = (None)]
[Debug: Force rwhois = No]
[Running /usr/bin/lynx -dump -post_data http://www.denic.de/en/whois/data.jsp ]
[Querying http://www.denic.de/en/whois/data.jsp]
[kupfer@antwort ~]$

After installing lynx it works.

Version-Release number of selected component (if applicable):
3.2.2

How reproducible:
Always

Steps to Reproduce:
1. whois 42h.de

  

Additional info:

Comment 1 Miloslav Trmač 2005-07-03 19:41:52 UTC
Thanks for your report.

Unfortunately the situation can't be solved with rpm; jwhois, if so configured,
can use other web browsers (w3m, maybe others) instead of lynx, if they can
submit POST forms in a way supported by jwhois.  Requiring lynx would be
unnecessarily specific, requiring "a web browser" not specific enough.

The only way I can see to represent the complete information is to add
"Provides: jwhois(supported-browser) = %{jwhois-version}" to each
of the supported browsers; that's just overengineered IMHO.


Note You need to log in before you can comment on or make changes to this bug.