Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161277 - High CPU load with Firefox 1.0.4
Summary: High CPU load with Firefox 1.0.4
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL: http://konstantin.antselovich.com/?p=14
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-21 22:51 UTC by Konstantin Antselovich
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-11-14 15:30:27 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Mozilla Foundation 298090 None None None Never

Description Konstantin Antselovich 2005-06-21 22:51:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050618 Firefox/1.0+

Description of problem:
Firefox takes unreasonably high % of CPU cicles on certain pages, which leads to it being unusanable. I had to use opera to view that particular page.
More details are here https://bugzilla.mozilla.org/show_bug.cgi?id=298090

I'm not familiar with Firefox codebase, I can confirm that the issue is fixed in current nightly builds, but those build have some other issues and cannot be taken as a base FC4 package.  

Version-Release number of selected component (if applicable):
firefox-1.0.4-4

How reproducible:
Always

Steps to Reproduce:
1. go to http://openpowerproject.org/us/index.php
2. whatch your CPU load goes through the roof 
3.
  

Actual Results:  CPU load aproaches 100%

Expected Results:  should take 10%-15%

Additional info:

browser becomes unusable, currently I'm not able to use standard FF from FC4 rpm for day-to-day browsing.

Comment 1 Adam Thompson 2005-06-26 19:44:07 UTC
Confirming... on a P4 2.8GHz cpu, trying 'firefox' at the command prompt results
in a ~20-second wait before the window renders on screen.
Then it takes another 30-40 seconds to display the default readme page.

Doing *anything* with Firefox (other than just looking at it :-) causes CPU to
spike to 100%... including just typing in a form field!

Tried the MOZ_DISABLE_PANGO=1 setting documented elsewhere in bugzilla, makes no
difference (seems even slower, actually).

Worth noting, though, is that firefox aside, the X binary seems to take up a LOT
of cpu time for... nothing.  A scrolling gnome-terminal spikes CPU to 100% for
as long as it's scrolling.  And that's on an AGP 4x ATI Rage 128, which should
have more than enough 2D framebuffer bandwidth to scroll its silly head off
without making the CPU even break a sweat.
Bottom line: *something* is making X take a *lot* of CPU cycles, no matter what app.
Attempting private build from source to see if problem is FF1.0.4 or the RPM
package.

Comment 2 Lonni J Friedman 2005-08-01 14:32:02 UTC
This is a 'me too'.  I've got an AMD Athlon(tm) XP 2700+ with 1GB RAM, and
firefox 1.06 is also painful to use with every pageload pegging the CPU for 1 or
more seconds.

Comment 3 Bart Vanbrabant 2005-08-07 13:26:52 UTC
It's probably the javescript ticker that is causing this. Like on this page:
http://www.php-tools.net/site.php
Add-block can do wonders on these pages :)

Comment 4 Adam Thompson 2005-08-07 17:40:11 UTC
I'm afraid it's not javascript-related.
Sitting on "about:blank" and merely moving the mouse pointer over the window
causes the CPU to peg at 100% until I move the mouse pointer away.
I'm not certain the problem is Firefox-related, as everything else on my FC4
system seems to be about 50% as fast as it was under FC3.

Comment 5 Fred New 2006-01-15 12:11:01 UTC
I am seeing similar problems with firefox-1.0.7-1.1.fc4 trying to access
http://www.delfi.ee/.

Comment 6 Konstantin Antselovich 2006-11-14 15:30:27 UTC
that was fixed  definitely  fixed in firefox 1.5.x.x 


Note You need to log in before you can comment on or make changes to this bug.