Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161266 - Unusably slow performance when browsing project (for the first time?)
Summary: Unusably slow performance when browsing project (for the first time?)
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-cdt
Version: 4
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeff Johnston
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-21 21:41 UTC by Dave Malcolm
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-10-04 19:03:46 UTC


Attachments (Terms of Use)

Description Dave Malcolm 2005-06-21 21:41:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.0.4-1.4.1 Firefox/1.0.4

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1. Create a Standard Make C project, set the project contents to be a non-standard directory outside the workspace (one of my source trees from an untarred source tarball of ximian-connector-2.0.2, as it happens, mounted on a local filesystem, not NFS)
2. Try to browse the project in the C/C++ Projects tab by expanding one of the tree nodes


Actual Results:  Eclipse becomes unresponsive for a long time, and eventually shows the expanded form of the node; CPU usage is close to 100%

Looking in top, the top process is "java".  Doing an strace -p on the PID, it appears that every file in that level of the project is being opened and the first roughly 30 bytes of each file is being read, one byte at a time.  (perhaps  doing MIME sniffing)

Problem appears to be one-time only; I could reproduce it.

Expected Results:  Should be able to expand tree nodes in the project instantaneously

Additional info:

eclipse-cdt-3.0.0_fc-0.M6.7
eclipse-platform-3.1.0_fc-0.M7.7
eclipse-bugzilla-0.1.0_fc-16
eclipse-ecj-3.1.0_fc-0.M7.7
eclipse-jdt-3.1.0_fc-0.M7.7
eclipse-changelog-2.0.1_fc-21

Doesn't seem to be so bad on a upstream Eclipse running on the Sun JDK

Comment 1 Dave Malcolm 2005-06-21 23:17:55 UTC
"Problem appears to be one-time only; I could reproduce it." should have read
"roblem appears to be one-time only; I couldn't reproduce it."

Comment 2 Ben Konrath 2006-10-04 19:03:46 UTC
This bug is filed against FC4 which is no longer supported. Please re-test with
FC5 or FC6 and reopen the bug if the problem still exists. Thanks.


Note You need to log in before you can comment on or make changes to this bug.