Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161263 - Installer crashes while partitioning
Summary: Installer crashes while partitioning
Keywords:
Status: CLOSED DUPLICATE of bug 147358
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-21 20:46 UTC by Arlen Abraham
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-21 21:15:01 UTC


Attachments (Terms of Use)

Description Arlen Abraham 2005-06-21 20:46:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Description of problem:
The installer will crash when it goes to partition the drive. This happens both in the GUI installer and the text based one. I set the partitions to autoconfigure. Sometimes it will just hang, sometimes it gives me the following.

Traceback (most recent call last):
 File "/usr/bin/anaconda", lin 1160, in ?
  omtf/run(id, dispatch)
 File "/usr/lib/anaconda/test.py", line 496, in run
   dispatch.gotoNext()
 File "usr/lib/anaconda/dispatch.py", line 242, in MoveStep
   rc = apply(finc, self.bindArgs(args))
 File "usr/lib/anaconda/packages.py", line 582, in TurnOnFilesystems
   thefsset.createLogicalVolumes(instPath)
 File "usr/lib/anaconda/fsset.py" line 1477, in createLogicalVolumes
   entry.device,setupDevice(chroot)
 File "usr/lib/anaconda/fsset.py" line 2131, in setupDevice
   raise SystemError, "lvcreate failed for %s" %s(self.name,)
SystemError:lvcreate failed for LogVol00 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot FC4 DVD in a ThinkPad 600x
2. Do either text or GUI install
3. Choose desktop install
4. Choose default options (including auto-partition)
5. Hit go
  

Actual Results:  As soon as you hit go, a small window pops up showing format progress. This move a small ammount and then hang. Sometimes a traceback appears, sometimes it doesn't.

Expected Results:  It should have formated the drive.

Additional info:

Perhaps it's the laptop's fault.

Comment 1 Chris Lumens 2005-06-21 21:15:01 UTC

*** This bug has been marked as a duplicate of 147358 ***


Note You need to log in before you can comment on or make changes to this bug.