Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161262 - rpm crash or hang when provided wrong URL
Summary: rpm crash or hang when provided wrong URL
Keywords:
Status: CLOSED DUPLICATE of bug 160615
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-21 20:22 UTC by Hans Deragon
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-13 10:20:18 UTC


Attachments (Terms of Use)

Description Hans Deragon 2005-06-21 20:22:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Tried the following:

# rpm -Uhv http://yahoo.com/apt.rpm
Retrieving http://yahoo.com/apt.rpm
error: skipping http://yahoo.com/apt.rpm - transfer failed - Unknown or unexpected error
Segmentation fault

Of course, the URL is bogus.  But that is the point.  RPM should abort gracefully in such condition.

Here is a different case.  Unfortunatly, it only occurs within our internal network and thus, I cannot provide an example on the Internet you can try.  In this case, rpm hangs.

rpm -Uhv http://someserver/fedora/4/i386/apt.rpm
Retrieving http://someserver/fedora/4/i386/apt.rpm
error: open of <!DOCTYPE failed: No such file or directory
error: open of HTML failed: No such file or directory
error: open of PUBLIC failed: No such file or directory
<hang here>

Version-Release number of selected component (if applicable):
4.4.1-21

How reproducible:
Always

Steps to Reproduce:
See description.

Additional info:

Comment 1 Jeff Johnson 2005-07-13 10:20:18 UTC

*** This bug has been marked as a duplicate of 160615 ***


Note You need to log in before you can comment on or make changes to this bug.