Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161247 - install exited abnormally
Summary: install exited abnormally
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
: 162659 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-21 18:28 UTC by David Sledge
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-24 19:32:13 UTC


Attachments (Terms of Use)

Description David Sledge 2005-06-21 18:28:00 UTC
Description of problem: Cannot install a fresh version FC4 with the graphical
install or the text install.


Version-Release number of selected component (if applicable):


How reproducible:
Fails every time.

Steps to Reproduce:
1. Download and check the ISO's against Fedora's sha1 sums
2. Burn the ISO's to cds
3. Boot off the cds and let anaconda try to run
  
Actual results: 
Running anaconda, the Fedora Core system installer - please wait...
'import site' failed; use -v for traceback
Traceback (most recent call last):
    File "/usr/bin/anaconda", line 358, in ?
        from exception import handleException
    File "/usr/lib/anaconda/exception.py", line 24, in ?
        import rpm
    File "/usr/lib/python2.4/site-packages/rpm/__init__.py", line 7, in ?
        from _rpm import *
ImportError: /usr/lib/libstdc++.so.6: cannot read file data: Is a directory
install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0
        /proc/bus/usb done
        /proc done
        /dev/pts done
        /sys done
        /tmp/ramfs done
        /mnt/source done
        /selinux done
you may safely reboot your system


Expected results:
Installer should run.

Additional info:
I have checked the sha1sum with the sums on the Fedora website and all ISO sums
checkout ok. I have also burned the cds using "cdwriter", "xcdroast" and
"cdrecord". When running the mediacheck they all fail. I have also downloaded
the ISO's with a different computer that is currently running FC3. I then burned
them and tried to install them on that second computer and had the same problem.

Comment 1 Chris Lumens 2005-06-21 21:12:03 UTC
Please attach your /tmp/anacdump.txt file to this report.

Comment 2 David Sledge 2005-06-21 21:42:48 UTC
I can't seem to catch it. As soon as the error happens everything unmounts and
the  terminal on tty2 locks. Is there any other way to get to this file?

Comment 3 David Sledge 2005-06-22 18:00:35 UTC
I have found that using cdrecord with the following options has created working
cd images "cdrecord dev=/dev/hdd -dao -eject speed=52 driveropts=noburnfree
FC4-i386-disc1.iso".


Comment 4 Chris Lumens 2005-06-24 19:32:13 UTC
Closing based on previous comment.  Perhaps we need to add this sort of
information to the documentation for future reference.

Comment 5 Alan Cox 2005-07-11 09:48:53 UTC
*** Bug 162659 has been marked as a duplicate of this bug. ***

Comment 6 Davide Rossetti 2005-07-11 10:19:49 UTC
why is  Bug 162659 considered similar to this one ??? they seem quite different
beasts ...

Comment 7 Fabian Rahm 2005-09-12 16:39:45 UTC
I am having the same issues as the original submitter (sha1 OK, media check
fails). I burned it with CD Burner XP Pro on Windows XP. What can cause the
burning program to cripple my installation disks for no obvious reason? 


Note You need to log in before you can comment on or make changes to this bug.