Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161239 - Corrupted screen with KDE and nv module
Summary: Corrupted screen with KDE and nv module
Keywords:
Status: CLOSED DUPLICATE of bug 157715
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-21 16:46 UTC by Marco
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-23 17:33:34 UTC


Attachments (Terms of Use)
xorg log file (deleted)
2005-06-21 16:46 UTC, Marco
no flags Details
xorg configuration file (deleted)
2005-06-21 16:47 UTC, Marco
no flags Details
corrupted screen (deleted)
2005-06-21 16:48 UTC, Marco
no flags Details

Description Marco 2005-06-21 16:46:11 UTC
Description of problem:
With KDE I've a corrupted screen after some time that I use it. Seem to appear
only with KDE, at random time, but I've also find a way to reproduce always, see
below.
With Gnome I cannot reproduce the problem.

my conf:
FC4-x86_64 final
Athlon64 3000+
1 GB of ram
GeForce6600 GT
nv module (no nvidia module installed)


Version-Release number of selected component (if applicable):
kde 3.4.1-0.fc4.1
xorg 6.8.2-37


How reproducible:
Always

Steps to Reproduce:
1. open KDE
2. open control center
3. go to system administrator
4. go to login manager
5. click on administrator mode
6. insert root password 
7. corruption starts.

Actual results:
screen is corrupted
see attachment

Expected results:
screen will stay normal

Additional informations:
Also seen that it appears an image of Windows XP logout with corruption, (I've
both OS installed), but don't know why!!!

Comment 1 Marco 2005-06-21 16:46:37 UTC
Created attachment 115759 [details]
xorg log file

Comment 2 Marco 2005-06-21 16:47:06 UTC
Created attachment 115760 [details]
xorg configuration file

Comment 3 Marco 2005-06-21 16:48:10 UTC
Created attachment 115761 [details]
corrupted screen

Comment 4 Mike A. Harris 2005-06-22 19:10:36 UTC
As an aide to troubleshooting, please add the following option to
the Device section of your xorg.conf, and restart:

    Option "noaccel"

After this, try to reproduce the problem, and be sure to use X long enough
to hopefully trigger the issue.  Update the report to let us know if this
prevents the issue.  If this is the case, please remove the above option,
and try using the following option instead:

    Option "XaaNoScreenToScreenCopy"

Now try to reproduce the issue again as above and indicate back wether the
issue still remains or not.

This will help to narrow down the problem domain.

There are other GeForce 6x00 related bug reports open in Red Hat and
Freedesktop.org bugzilla which you might want to query for also, as you
may be experiencing a problem already reported.  One bug we're tracking,
which has been confirmed by a few users on GeForce 6200 and 6800, is
bug #157715.  It's possible the issue also affects the 6600 cards as well.

Hope this helps.


Setting status to "NEEDINFO", awaiting results of testing with 'noaccel'
and "XaaNo....".

Comment 5 Marco 2005-06-23 10:58:48 UTC
Both with noaccel and XaaNo... (not at the same time) corruption seems to have gone.
The problem is with this options the card is very slow, only scrolling with a
browser take a long time.

Comment 6 Mike A. Harris 2005-06-23 17:33:34 UTC
Ok, thanks for the testing.  I think it's safe to conclude that this problem
affects GeForce 6600 now in addition to the previously known cards.  When we
find a fix we'll be sure to enable it for 6600 also.  Marking this as a dupe
of the master bug...



*** This bug has been marked as a duplicate of 157715 ***

Comment 7 Marco 2005-06-23 17:57:11 UTC
Yes, but the master bug is a bit different, I have problems with KDE and NOT
with GNOME or the installation!

Comment 8 Mike A. Harris 2005-06-23 18:18:32 UTC
The common issue, is the "nv" video driver being busted on GeForce 6200,
6600, 6800 hardware, all with the same symptoms and with the same diagnosis.
The same workaround prevents the problem on all of the hardware.

The actual desktop environment differing is not relevant to the problem,
which is why this is a duplicate of the master bug.  In other words, when
the video driver is fixed, the problem will be resolved regardless of what
desktop you use.

Hope this clarifies things...



Note You need to log in before you can comment on or make changes to this bug.