Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161234 - Can't edit files in a ftp folder
Summary: Can't edit files in a ftp folder
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: bluefish
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phillip Compton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-21 16:09 UTC by José Salgado
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-21 11:00:39 UTC


Attachments (Terms of Use)

Description José Salgado 2005-06-21 16:09:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.7.8) Gecko/20050524 Fedora/1.0.4 Firefox/1.0.4

Description of problem:
Open a ftp folder (created with nautilus) open a file and when you try to save the bluefish hangs. If you do it from the terminal, yoy can see that:

[tatxe@iglu ~]$ bluefish

(bluefish:8853): libgnomevfs-WARNING **: gnome-vfs-monitor.c: A monitor handle was destroyed before it was added to the method hash table. This is a bug in the application and can cause crashes. It is probably a race-condition.

Version-Release number of selected component (if applicable):
bluefish-1.0-4

How reproducible:
Always

Steps to Reproduce:
1.Open a file from a ftp server
2.Write something
3.Save
  

Actual Results:  bluefish hangs.

Expected Results:  Save the file

Additional info:

[tatxe@iglu ~]$ rpm -qa gnome-vfs*
gnome-vfs2-smb-2.10.0-5
gnome-vfs2-2.10.0-5

Comment 1 Jim Hayward 2005-07-01 13:05:43 UTC
Could you please file a bug upstream in GNOME bugzilla against Bluefish. I can't
reproduce this with bluefish 1.0.2 compiled from sources on my FC4 system. The
Extras package appears to be compiled without libgnomeui. libgnomeui is an
optional, but recommended dependency. I'm assuming right now you are
encountering a bug if bluefish is compiled without libgnomeui.

http://bugzilla.gnome.org/



Comment 2 Jim Hayward 2005-07-05 02:43:42 UTC
Can you please test the 1.0.2 FC4 RPM on the Bluefish master server to see if
your problem is fixed. This RPM is compiled with libgnomeui support. Thanks.

http://pkedu.fbt.eitn.wau.nl/~olivier/downloads/

Comment 3 José Salgado 2005-07-05 05:54:38 UTC
I works fine now. Thanks a lot.

Comment 4 Paul Howarth 2005-07-15 14:23:37 UTC
How about updating Fedora Extras to 1.0.2 and building it with libgnomeui support?

Comment 5 Jim Hayward 2005-07-16 03:39:57 UTC
It's up to the bluefish package maintainer for Fedora Extras to so this.
Compiling with libgnomeui support is the current workaround for the bug. I'm not
the package maintainer for Extras. I'm an upstream bluefish developer. I built
the RPM on the Bluefish server. The bug when compiling without libgnomeui has
not ben fixed upstream yet. Although even if it was fixed, I would still
recommend compiling with libgnomeui.

Comment 6 Michael Schwendt 2005-07-16 10:29:47 UTC
Reopining ticket, since if I understand comment 2 and comment 3 correctly, this
bug still applies to the Fedora Extras package.

Comment 7 Jim Hayward 2005-07-16 13:08:46 UTC
Yes, the current Extras Bluefish 1.0 RPM is apparently effected by a bug in
bluefish. libgnomeui is an optional dependency. Compiling with libgnomeui
appears to work around the problem. 

Comment 8 Paul Howarth 2005-07-21 10:19:18 UTC
Since the OP has now closed this bug twice despite there not being a fix for the
package in Fedora Extras, I've raised a new bug to keep this issue open:
Bugzilla #163804

Comment 9 Paul Howarth 2005-07-21 10:21:03 UTC
Whoops; didn't mean to reopen this bug. Sorry about that.


Note You need to log in before you can comment on or make changes to this bug.