Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161227 - Specifying root filesystem in grub via UUID
Summary: Specifying root filesystem in grub via UUID
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mkinitrd
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-21 15:34 UTC by Wendy Cheng
Modified: 2018-10-19 20:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-19 18:59:42 UTC


Attachments (Terms of Use)

Description Wendy Cheng 2005-06-21 15:34:24 UTC
Description of problem:
There are merits of specifying root filesystem in grub using UUID since disk
label doesn't fit the need. For example, in a real world case, when a panic
system got rebooted, it picked up the wrong lun (root partition) from the shared
SAN since someone just newly created a new root partition (lun) for another host
using the very same disk label. It took a while to figure out what went wrong
because the system was panicked before that reboot.   

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jeremy Katz 2005-06-21 17:41:17 UTC
UUID has the downside of being completely incomprehensible to a user :)

LABEL is the best compromise between something that can be understood and
something that is relatively resilient to disks moving around.

Comment 10 Red Hat Bugzilla 2007-02-05 19:16:05 UTC
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.

Comment 11 RHEL Product and Program Management 2007-10-19 18:59:42 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.