Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161223 - Fatal Python error: can't initialise module gtksourceview
Summary: Fatal Python error: can't initialise module gtksourceview
Keywords:
Status: CLOSED DUPLICATE of bug 162403
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-python2-extras
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-21 15:09 UTC by Gilboa Davara
Modified: 2013-04-02 04:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-25 21:34:01 UTC


Attachments (Terms of Use)

Description Gilboa Davara 2005-06-21 15:09:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
In an attempt to use Meld's syntax coloring, I've installed the required library chain using yum. (Default configuration; extra repo active) 
gnome-python2-gtksourceview-2.10.0-2.1.x86_64
gnome-python2-extras-2.10.0-2.1.x86_64
meld-0.9.6-1


Version-Release number of selected component (if applicable):
meld-0.9.6-1

How reproducible:
Always

Steps to Reproduce:
1. yum install gtksourceview gnome-python-extras gnome-python2-gtksourceview meld
2. $ meld

Actual Results:  Meld dies with:
"Fatal Python error: can't initialise module gtksourceview
Aborted" error.



Expected Results:  meld's syntax coloring should be available.

Additional info:

If I remove the gnome-python2-gtksourceview RPM, meld starts-up just fine. (Though I cannot enable the syntax coloring option.)

Comment 1 Michael Schwendt 2005-07-25 19:30:18 UTC
I believe this is a broken gnome-python2-gtksourceview package in Core:

$ python
Python 2.4.1 (#1, May 16 2005, 15:19:29) 
[GCC 4.0.0 20050512 (Red Hat 4.0.0-5)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import gtksourceview
Fatal Python error: can't initialise module gtksourceview
Aborted

$ pwd
/usr/share/doc/gnome-python2-gtksourceview-2.10.0
$ python test-widget.py 
Fatal Python error: can't initialise module gtksourceview
Aborted

Comment 2 Gilboa Davara 2005-07-25 20:32:47 UTC
Oh... this bugs might be duplicate:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=162403


Comment 3 Gilboa Davara 2005-07-25 20:34:00 UTC
s/bugs might be/bug might be a/g

Comment 4 Michael Schwendt 2005-07-25 21:34:01 UTC

*** This bug has been marked as a duplicate of 162403 ***


Note You need to log in before you can comment on or make changes to this bug.