Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161222 - No mailbox for user $username on $servername
Summary: No mailbox for user $username on $servername
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-connector
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-21 15:03 UTC by Samuel Irlapati
Modified: 2018-04-11 15:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-31 15:59:30 UTC


Attachments (Terms of Use)

Description Samuel Irlapati 2005-06-21 15:03:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I upgraded from FC3 to FC4. Now when i try to use evolution with Microsoft exchange i get the error that "No mailbox for user $username on $servername". The path for me email when using OWA has my first and last name in the path. But when i go to the evolution settings there seems to be no way to tell it like how there used to be before. 

Version-Release number of selected component (if applicable):
evolution-connector-2.2.2-5

How reproducible:
Always

Steps to Reproduce:
My settings are as follows.
1. edit -> preferences and selecting my email account.
2. I select Microsoft Exchange as my server type.
3. for Username, i have my username which is "irlapasj"
4. For owa url: i have, "http://ustr-exch5/exchange/samuel.irlapati"
5. Authentication type "Plaintext Password"


  

Actual Results:  After hittong ok, i try to check my email and ir prompts for my password. When I enter my password i get the error "No mailbox for user irlapasj on ustr-exch5.tr.unisys.com."

Expected Results:  I would expect to see my email or all the folders on the server.

Additional info:

Here is the string value from .gconf/apps/evolution/%gconf.xml

<stringvalue>&lt;?xml version=&quot;1.0&quot;?&gt;
&lt;account name=&quot;Work&quot; uid=&quot;1119298585.7717.0@ustr-irlapasj-1&quot; enabled=&quot;true&quot;&gt;&lt;identity&gt;&lt;name&gt;Samuel Irlapati&lt;/name&gt;&lt;addr-spec&gt;Samuel.Irlapati@Unisys.com&lt;/addr-spec&gt;&lt;organization&gt;Unisys Corp&lt;/organization&gt;&lt;signature uid=&quot;&quot;/&gt;&lt;/identity&gt;&lt;source save-passwd=&quot;true&quot; keep-on-server=&quot;false&quot; auto-check=&quot;false&quot; auto-check-timeout=&quot;30&quot;&gt;&lt;url&gt;exchange://irlapasj;auth=Basic@ustr-exch5.tr.unisys.com/;ad_server=ustr-nadc2.na.uis.unisys.com;filter_junk_inbox;owa_url=http://ustr-exch5/exchange/samuel.irlapati&lt;/url&gt;&lt;/source&gt;&lt;transport save-passwd=&quot;true&quot;&gt;&lt;url&gt;exchange://irlapasj;auth=Basic@ustr-exch5.tr.unisys.com/;ad_server=ustr-nadc2.na.uis.unisys.com;filter_junk_inbox;owa_url=http://ustr-exch5/exchange/samuel.irlapati&lt;/url&gt;&lt;/transport&gt;&lt;drafts-folder&gt;mbox:/home/irlapasj/.evolution/mail/local#Drafts&lt;/drafts-folder&gt;&lt;sent-folder&gt;mbox:/home/irlapasj/.evolution/mail/local#Sent&lt;/sent-folder&gt;&lt;auto-cc always=&quot;false&quot;&gt;&lt;recipients&gt;&lt;/recipients&gt;&lt;/auto-cc&gt;&lt;auto-bcc always=&quot;false&quot;&gt;&lt;recipients&gt;&lt;/recipients&gt;&lt;/auto-bcc&gt;&lt;pgp encrypt-to-self=&quot;false&quot; always-trust=&quot;false&quot; always-sign=&quot;false&quot; no-imip-sign=&quot;false&quot;/&gt;&lt;smime sign-default=&quot;false&quot; encrypt-default=&quot;false&quot; encrypt-to-self=&quot;false&quot;/&gt;&lt;/account&gt;

Comment 1 Dave Malcolm 2005-06-21 20:22:59 UTC
Looks like it's sending your username rather than mailbox name to the Exchange
server; this is a known bug, unfortunately, and we don't have a fix yet.

Comment 2 Joerg Battermann 2005-07-14 11:25:05 UTC
I can confirm the bug - having the same problem. My Hosted Exchange environment 
uses https://server/mailboxname (in my case jb) as setup, and I get an error 
message "no mailbox jb at server" too :\

Comment 3 Sharon O'Donnell 2005-10-07 21:22:30 UTC
Just switched from FC3 to FC4 - evolution 2.04 worked under FC3.

When I try to read my folders now, I first get,

Mailbox for odonnell is not on this server.

This is followed with,

Error while Scanning folders in "Exchange server <server>".
Lost connection to Evolution Exchange backend process.

Upgraded to evolution 2.2.3 and evolution-data-server-1.2.3-3, still have the
problem. 



Comment 5 Christian Iseli 2007-01-20 00:51:49 UTC
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.

Comment 6 Matěj Cepl 2007-08-31 15:20:17 UTC
The distribution against which this bug was reported is no longer supported,
could you please reproduce this with the updated version of the currently
supported distribution (Fedora Core 6, or Fedora 7, or Rawhide)? If this issue
turns out to still be reproducible, please let us know in this bug report.  If
after a month's time we have not heard back from you, we will have to close this
bug as INSUFFICIENT_DATA.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.

Comment 7 Samuel Irlapati 2007-08-31 15:58:48 UTC
It works now in Fedora 7.


Note You need to log in before you can comment on or make changes to this bug.