Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161214 - Anaconda fails during network text install with language different than english (French, Dutch, ...)
Summary: Anaconda fails during network text install with language different than engli...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On: 159329
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-06-21 14:25 UTC by Christian P. MOMON
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-05 17:51:18 UTC


Attachments (Terms of Use)
Python trace of anaconda crash (deleted)
2005-06-21 14:31 UTC, Christian P. MOMON
no flags Details

Description Christian P. MOMON 2005-06-21 14:25:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
Same as explain in the bug #159329: using the http install way, anaconda crash when you choose a different language than english (French, Dutch, ...).
See attachment file trace.
This bug was detected in the fc4test1 (#159329) and it is again in the final release. By the way, actually http install is NOT possible for most people on the world.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Burn boot.iso (network install)
2. Boot from burned CD. (choose HTTP source with)
3. Choose language 'French' and keyboard 'fr-latin1' during install process
4. After downloading netstg2 image from net and starting anaconda, it fails.

Actual Results:  Error message: "[...]IOError: CRC check failed, install exited abnormally[...]"


Expected Results:  The installer should continue.

Additional info:

I tried with different computer (COMPAQ PIII 450) and three differents burned CD. And i verified twice the boot.iso file.

Comment 1 Christian P. MOMON 2005-06-21 14:31:01 UTC
Created attachment 115748 [details]
Python trace of anaconda crash

Manually copy of the trace display when anaconda failed.

Comment 2 Chris Lumens 2005-06-22 14:39:01 UTC
I am unable to reproduce this problem.  What location are you installing from?

Comment 3 Christian P. MOMON 2005-06-24 22:23:46 UTC
Hoooo, strange. Me too, with a Pundit ASUS: success!
So, i must determin why it's failed with a COMPAQ DESKPRO PIII 450Mhz. I'll be back.

Comment 4 Christian P. MOMON 2005-06-25 01:37:15 UTC
Note: on the Pundit it's a graphical install, on the Compaq it is a text gui one
(when i choose 'English'). The integrated graphic card seems to be a ATI Rage
Mach64 (this is what system-config-display print).
So, now, the question is: why text-gui HTTP install crash when you choose French
language?

Comment 5 Christian P. MOMON 2005-06-26 09:12:46 UTC
The bug is only in text mode. I success to reproduce it on the Pundit using the
'linux text' command on prompt of the boot.iso cd-rom. I updated the summary.

Steps to Reproduce:
1. Burn boot.iso (network install)
2. Boot from burned CD.
3. On prompt, enter 'linux text'
4. Choose language 'French' and keyboard 'fr-latin1' during install process
5. Choose HTTP source and set some network config
6. After downloading image from net and starting anaconda, it fails.

Can you test to reproduce it? :-)

Comment 6 Chris Lumens 2005-06-27 15:15:02 UTC
Yes, I am now able to reproduce using a text mode install.

Comment 7 Chris Lumens 2005-06-30 15:56:47 UTC
This looks like a bug in our compressed file reading code, which really should
die in favor of what's in python these days.

Comment 8 Chris Lumens 2005-06-30 18:24:47 UTC
Will test with new rhpl after the weekend and see if I got it.

Comment 9 Christian P. MOMON 2005-07-05 18:17:21 UTC
Congratulations!!! :-)
Is there a solution for FC4 users?

Comment 10 Chris Lumens 2005-07-05 18:56:25 UTC
We may be putting together an updates.img for fixing this (and a couple other
problems) in the near future.  Since it's a bug in the installer, we can't just
release a regular Fedora update for it.

Comment 11 Christian P. MOMON 2005-07-05 21:39:21 UTC
I am agree with you, updates.img will be sufficient.
Is the bug located in the boot.iso or in another place? Perhaps downloadable
boot.iso could be easy.
Congratulations again! :-)


Comment 12 Eric Doutreleau 2005-07-12 12:18:14 UTC
is there some news about the updates.imd disk
i have still the problem duting kickstart installation.


Note You need to log in before you can comment on or make changes to this bug.