Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161196 - Installer installs unwanted packages in custom or minimal modes
Summary: Installer installs unwanted packages in custom or minimal modes
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
: 163250 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-21 10:11 UTC by Baptiste SIMON
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-03 20:20:17 UTC


Attachments (Terms of Use)

Description Baptiste SIMON 2005-06-21 10:11:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; fr; rv:1.7.6) Gecko/20050524 Firefox/1.0 (Ubuntu package 1.0.2 MFSA2005-44)

Description of problem:
when trying to install a minimalist Fedora Core 4 system using the "minimal" installation option (in the graphical mode) or using the "custom" one (in text mode) and unselecting everything, the FC4 installer always installs openoffice.org-core and maybe other packages that I don't want on my minimalist system !

something else : the list of languages is not ordered alphabetically.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. insert the FC4 installation CD1, and boot your computer on it
2. setup your system
3. choose the "custom" mode and unselect every group of packages
4. start the installation...

Actual Results:  1. the installer is looking for the 4 CDs whereas FC2 & FC3 installation process was only asking for the CD1 and CD3.
2. 'rpm -q openoffice.org-core' shows that this is installed :c(

Expected Results:  Maybe only the 2 CDs (CD1 & CD3) are needed w/ a minimalist system
only the needed packages might be present on such a system (nothing about openoffice.org-core).

Additional info:

Comment 1 Jeremy Katz 2005-06-21 17:34:36 UTC
Can you please provide /root/anaconda-ks.cfg and /var/log/anaconda*?

Comment 2 Baptiste SIMON 2005-06-22 12:12:09 UTC
I can... ;c)

/root/anaconda-ks.cfg :
- -- ---
# Kickstart file automatically generated by anaconda.

install
cdrom
lang fr_FR.UTF-8
langsupport --default=fr_FR.UTF-8 fr_FR.UTF-8 fr_FR fr fr_FR.UTF-8 fr_FR fr
keyboard fr-latin1
xconfig --card "SiS 530/620" --videoram 8192 --hsync 30-72 --vsync 50-120
--resolution 800x600 --depth 16
network --device eth0 --bootproto static --ip 192.168.xxx.xxx --netmask
255.255.255.xxx --gateway 192.168.xxx.xxx --nameserver
xxx.xxx.xxx.xxx,xxx.xxx.xxx.xxx --hostname glop
rootpw --iscrypted $1$KTTo5/GL$JJ7/QNgx5a7z0QAe5usdM1
firewall --disabled
selinux --disabled
authconfig --enableshadow --enablemd5
timezone Europe/Paris
bootloader --location=mbr --driveorder=hda
# The following is the partition information you requested
# Note that any partitions you deleted are not expressed
# here so unless you clear all partitions first, this is
# not guaranteed to work
#clearpart --linux
#part /boot --fstype ext3 --onpart hda2
#part / --fstype ext3 --onpart hda3
#part swap --onpart hda5

%packages
@ dialup
@ java
@ french-support
kernel
grub
kernel-devel
e2fsprogs

%post
- -- ---

my anaconda.log is here : [ http://stock.e-glop.net/anaconda.log ]

Comment 3 Chris Lumens 2005-06-22 13:55:49 UTC
I think what's happening here is that the french-support package is pulling in
the openoffice.org-french package, which requires openoffice.org-core package. 
I'll take a look at this.

Comment 4 Baptiste SIMON 2005-06-22 14:01:15 UTC
But, I repeat : everything is desactivated at the packages selection time, even
language support... so I can't understand why french-support is installed.

thanks for your attention :c)

Comment 5 Chris Lumens 2005-06-22 14:33:21 UTC
french-support would have been automatically selected if you did the
installation in French, which it looks to me like you did given the "lang" and
"langsupport" settings from your anaconda-ks.cfg.  This may be a poor
assumption, but right now we assume that if you install in a certain language,
this is the language you want to be using by default on the system after
installation is completed.

Now if you weren't installing in French, something weird is going on.

Comment 6 Baptiste SIMON 2005-06-22 14:37:56 UTC
yes, I'm installing in French... but I've unselected "language support" in the
packages selection.

whatever, the matter is : why does the installer is selecting the
openoffice.org-french package... and maybe others because, since the FC4, I need
the 4 installation CDs whereas only the 1st and the 3rd were needed in FC2 & FC3.

Comment 7 Chris Lumens 2005-07-14 15:07:39 UTC
*** Bug 163250 has been marked as a duplicate of this bug. ***

Comment 8 Chris Lumens 2005-09-23 15:59:35 UTC
Package selection is undergoing extensive changes in Rawhide, so I'll test this
after we're done with those modifications and see if it's still broken.

Comment 10 Chris Lumens 2006-08-03 20:20:17 UTC
This should be fixed for FC6.


Note You need to log in before you can comment on or make changes to this bug.