Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161180 - (POWER MANAGEMENT?) Kernel hangs after flood of Atapi errors
Summary: (POWER MANAGEMENT?) Kernel hangs after flood of Atapi errors
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Alan Cox
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-21 06:09 UTC by Arthur Pemberton
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-04 05:47:33 UTC


Attachments (Terms of Use)

Description Arthur Pemberton 2005-06-21 06:09:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.7.8-2

Description of problem:
Twice for today, I have returned after leaveing the computer on, logged in, with applications open, but doing nothign special for long periods of time. On these two occassions I returned to meet my machine completely stalled. I had to use the restart button to get back to work.

On restart fsck does not run, boot is normal except for a failed mknod issue.

My /var/log/messages is flooded with a looping error which I have attached. MY installion of FC4 is only 3 days old. I have no suspicious apps running during these stalls.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1369_FC4

How reproducible:
Didn't try


Additional info:

<-- error loop block start -->
Jun 19 22:13:02 Juilet kernel: ATAPI device hdc:
Jun 19 22:13:02 Juilet kernel:   Error: Illegal request -- (Sense key=0x05)
Jun 19 22:13:02 Juilet kernel:   Command sequence error -- (asc=0x2c, ascq=0x00)
Jun 19 22:13:02 Juilet kernel:   The failed "Prevent/Allow Medium Removal" packet command was:
Jun 19 22:13:02 Juilet kernel:   "1e 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 "
Jun 19 22:13:02 Juilet kernel: hdc: packet command error: status=0x51 { DriveReady SeekComplete Error }
Jun 19 22:13:02 Juilet kernel: hdc: packet command error: error=0x50 { LastFailedSense=0x05 }
Jun 19 22:13:02 Juilet kernel: ide: failed opcode was: unknown
<-- error loop block end -->

# du -h /var/log/messages
157M    /var/log/messages

Comment 1 Arthur Pemberton 2005-07-10 23:08:56 UTC
I installed the latest kernel at 09:33 today:
    Jul 10 09:33:04 Installed: kernel.i686 2.6.12-1.1390_FC4

By 16:00 the kernel had crashed and burned again:
    Jul 10 16:00:24 Juilet kernel: ide: failed opcode was: unknown
    Jul 10 16:00:24 Juilet kernel: ATAPI device hdc:
    Jul 10 16:00:24 Juilet kernel:   Error: Illegal request -- (Sense key=0x05)
    Jul 10 16:00:24 Juilet kernel:   Command sequence error -- (asc=0x2c, ascq=0x00)
    Jul 10 16:00:24 Juilet kernel:   The failed "Prevent/Allow Medium Removal" 
   packet command was:
    Jul 10 16:00:24 Juilet kernel:   "1e 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 "
    Jul 10 16:00:24 Juilet kernel: hdc: packet command error: status=0x51 {
DriveReady SeekComplete Error }
    Jul 10 16:00:24 Juilet kernel: hdc: packet command error: error=0x50 {
LastFailedSense=0x05 }

Most of that time was low usage time as I was out for morning, and sleeping in
the afternoon. Niether did  I have anything to do with the cdrom during that time.

Comment 2 Alan Cox 2005-07-11 09:34:53 UTC
Is the machine going into power saving state when left idle like this ?


Comment 3 Arthur Pemberton 2005-07-11 14:51:56 UTC
Yes it does in fact. However, this is also true for kernel 2.6.12-1.1387_FC4
which I have regressed to. And what ever power saving settings are the stock
settings, as I have not reconfigured these settings.

Comment 4 Arthur Pemberton 2005-07-14 06:11:52 UTC
What ever the problem is, it is taking my machine down with all FC4 kernels.
This did not happen in FC3. Furthermore, fsck does not launch on reboot.

Comment 5 Arthur Pemberton 2005-07-15 04:07:17 UTC
I do not think this a power management issue. My machine froze literally within
seconds of runnign dmesg. Only the following relevant log messages showed up.

Jul 14 23:55:43 Juilet kernel: hdc: irq timeout: status=0xd0 { Busy }
Jul 14 23:55:43 Juilet kernel: ide: failed opcode was: unknown
Jul 14 23:55:43 Juilet kernel: hdc: DMA disabled
Jul 14 23:56:13 Juilet kernel: hdc: ATAPI reset timed-out, status=0xd0
Jul 14 23:56:13 Juilet kernel: hdd: DMA disabled
Jul 14 23:56:43 Juilet kernel: ide1: reset timed-out, status=0xd0
Jul 14 23:56:48 Juilet kernel: hdc: status timeout: status=0xd0 { Busy }
Jul 14 23:56:48 Juilet kernel: ide: failed opcode was: unknown
Jul 14 23:56:48 Juilet kernel: hdc: drive not ready for command
Jul 14 23:57:18 Juilet kernel: hdc: ATAPI reset timed-out, status=0xd0
Jul 14 23:57:48 Juilet kernel: ide1: reset timed-out, status=0xd0

Then the machine froze. I had to had reboot. Again. And fsck did not run on
reboot, again.

Also my CDRW (hdd) does not respond to its eject button while FC4 is on.

Comment 6 Dave Jones 2005-07-15 21:44:31 UTC
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.


Comment 7 Arthur Pemberton 2005-07-19 00:43:09 UTC
Gentlemen,

I am running kernel.i686 2.6.12-1.1398_FC4 and proud. As promised, this seemed
to have solved my issue. I am nolonger crashing when the machine is idle, and my
cdrw can open, my final test would be to burn a cd.

Thanks to all for the fix.


Note You need to log in before you can comment on or make changes to this bug.