Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161171 - ls -l command produces segmentation fault
Summary: ls -l command produces segmentation fault
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: bash
Version: 3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-21 00:45 UTC by Pat Dwyer
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-21 15:01:42 UTC


Attachments (Terms of Use)

Description Pat Dwyer 2005-06-21 00:45:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
The ls command serV's when I execute ls -l. If I execute ls or ls -R I'm okay. This behavior occurs as both a regular user and root.

I recently installed FC3-I386 on an INTEL CELERON (COMPAQ 5008US)
80 MHZ and about 380 ram.

I pulled the ISO's from redhat and checked them before I installed.

After install, I pulled lots of updates from the updater, although not all of them. I got what looked like all of the OS related ones.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open a terminal window
2.Execute ls -l
3.
  

Additional info:

Comment 1 Pat Dwyer 2005-06-21 00:47:56 UTC
It's really 800 MHZ.

Comment 2 Tim Waugh 2005-06-21 08:18:19 UTC
Can't reproduce this.

Please obtain a stack trace (see http://fedora.linux.duke.edu/wiki/StackTraces)
and attach it here.

Comment 3 Pat Dwyer 2005-06-21 14:56:57 UTC
Tim,

  I went to run GDB with the ls -l command and to my surprise the command works. 
I now get an output from ls -l. Since I'm certain that I was getting a seg V
before, I suspect that a problem still exists which makes this issue
intermittent.  When it happens again I will produce a stack trace and attach it
to the case.

Thanks so much for you help.

Paddy

Comment 4 Tim Waugh 2005-06-21 15:01:42 UTC
Please re-open if you see this again.


Note You need to log in before you can comment on or make changes to this bug.