Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161162 - OOo writer hangs on scrolling documents with many pictures
Summary: OOo writer hangs on scrolling documents with many pictures
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 4
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-20 21:31 UTC by Andrea Santilli
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 2.0.1-143.2.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-30 11:09:37 UTC


Attachments (Terms of Use)
OpenOffice.org Writer backtrace (deleted)
2005-07-14 21:48 UTC, Ian Pilcher
no flags Details

Description Andrea Santilli 2005-06-20 21:31:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When I scroll down documents containing a lot of pictures writer hangs.
Moreover on KDE (not on gnome) all the desktop seems to be hanged until I kill soffice.bin process.
Maybe it's a memory related issue.

Version-Release number of selected component (if applicable):
1.9.104-2

How reproducible:
Sometimes

Steps to Reproduce:
1. Open a document which contains many pics (sxw or odt) with OOo writer
2. Scroll down the document
3. writer hangs
  

Additional info:

Comment 1 Caolan McNamara 2005-06-21 07:57:46 UTC
attach a document which reproduces this for you.

Comment 2 Andrea Santilli 2005-06-30 10:52:58 UTC
That's a problem because the containt of the document is patented and I can't
attach it here. I just took the text and pictures from a web page, pasted them
on ooo writer (1.x) and reformatted the document.
Now the document hangs writer 2 :(

But there's a positive new in latest update (1.9.112-1.1.0.fc4): now when it
hangs on kde, it doesnt hang all the desktop environment anymore.

Last time writer hang, i did 
# kill -s SIGTRAP 18632
to try to unlock it but soon a dialog appeared. In the title there was written
"OOo has crashed: Paste this text into your bugreport"

The following text is the content of that dialog:

0xc30b0a: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1db0a
0xc31358: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e358
0x36b420:  + 0x420 (__kernel_sigreturn + 0x0)
0xabbd157b: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x13757b
0xabcff0fd: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2650fd
0xabd07e05: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x26de05
0xabd08bcd: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x26ebcd
0xabd07938: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x26d938
0xabd0894d: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x26e94d
0xabd07c5c: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x26dc5c
0xabcff11f: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x26511f
0xabd07e05: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x26de05
0xabd08bcd: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x26ebcd
0xabd07938: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x26d938
0xabd0894d: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x26e94d
0xabd07c5c: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x26dc5c
0xabcff3e0: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2653e0
0xabd014d3: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2674d3
0xabd01acd: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x267acd
0xabd01c58: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x267c58
0xabc33add: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x199add
(ViewShell::LayoutIdle() + 0x93)
0xabdbd287: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x323287
0xabdbd37a: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x32337a
0x64a302: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x7a302
0x655e8a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x85e8a
(Timer::Timeout() + 0x10)
0x656204: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x86204
0x3840251: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x42251
0x384023c: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x4223c
(SalData::Timeout() const + 0x24)
0x4b97332: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xa332
0x8c7af06: /usr/lib/libglib-2.0.so.0 + 0x24f06
0x8c793ee: /usr/lib/libglib-2.0.so.0 + 0x233ee (g_main_context_dispatch + 0x1dc)
0x8c7c3f6: /usr/lib/libglib-2.0.so.0 + 0x263f6
0x8c7c8d8: /usr/lib/libglib-2.0.so.0 + 0x268d8 (g_main_context_iteration + 0x66)
0x4b97515: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xa515
0x3846f41: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x48f41
(X11SalInstance::Yield(unsigned char) + 0x29)
0x650670: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x80670
(Application::Yield() + 0x50)
0x6506ae: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x806ae
(Application::Execute() + 0x26)
0x80667c7: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x1e7c7
(desktop::Desktop::Main() + 0x14a3)
0x655a93: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x85a93 (SVMain()
+ 0x45)
0x80618cb: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x198cb (sal_main +
0x47)
0x9103de6: /lib/libc.so.6 + 0x14de6 (__libc_start_main + 0xc6)
0x8061801: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x19801
(Window::RequestHelp(HelpEvent const&) + 0x31)


Comment 3 Caolan McNamara 2005-06-30 11:09:37 UTC
Well that's enough information to know that it is indeed hanging in writer's
layout. 

But I'd have to get a sample document to the writer layout developers to make
any progress on this :-(, I generally cannot debug what I cannot reproduce
locally. So I'll have to mark it as WONTFIX for now.

There have been similiar layout loops in the past. Perhaps give it a go with
1.9.113 out in a day or two and see if you get lucky and that resolves it. 

Comment 4 Ian Pilcher 2005-07-14 21:47:33 UTC
I have just seen this bug (or something very like it in
openoffice.org-writer-1.9.112-1.1.0.fc4.  I'm running under KDE, and it did
freeze the entire desktop until I killed it from a text console.

I'll attach the backtrace.

I'd be glad to share the document, but I can't reproduce the problem right now.
Do you still want it?

Comment 5 Ian Pilcher 2005-07-14 21:48:27 UTC
Created attachment 116771 [details]
OpenOffice.org Writer backtrace

Comment 6 Caolan McNamara 2005-07-15 07:10:01 UTC
Yeah, that backtrace is useful. It tells me that your problem is a known bug
with the clipboard (libdtrans) under kde. This one is fixed in rawhide 1,9,117-1
which will soon be updated for FC4.

Comment 7 Andrea Santilli 2005-12-20 02:13:02 UTC
This bug seems to be fixed in 2.0.1-143.2.1

Comment 8 Caolan McNamara 2005-12-20 08:54:22 UTC
Excellent


Note You need to log in before you can comment on or make changes to this bug.