Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161157 - tg3 module fails to work on kickstart process, this happens on rhas3
Summary: tg3 module fails to work on kickstart process, this happens on rhas3
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-20 21:05 UTC by its-systems
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-16 14:24:08 UTC


Attachments (Terms of Use)

Description its-systems 2005-06-20 21:05:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
Attempting to kickstart Dell 2650 servers, the kickstart process cannot get a IP from DHCP, attempted a manual IP also failed. Kickstart process works for Dell 2850 and NFS mounts work so the rest of the process is fine.

Version-Release number of selected component (if applicable):
original rhas3 and update 5

How reproducible:
Always

Steps to Reproduce:
1. #network module load for a 2650
device net tg3
device net e1000

2. Burn CD, try a kickstart install.
3. Standard install seems OK, but this means 12 seperate manual installs...with no disaster recovery so is really not wanted.
  

Actual Results:  Says cannot mount at 130.195.20.239 /redhat/rhas3-5

Expected Results:  Mount should happen and kickstart completes, this works for Dell 1850s, 2850s (-64 arch), Dell 2300s (x86) and various Fedora test beds. Most units use the e100 or e1000 so this suggests a problem with the tg3 module.

Additional info:

Dell 2650

Comment 1 John W. Linville 2005-06-21 19:04:01 UTC
Have you tried booting the 2650 w/ either "noapic", "acpi=noirq" or 
"acpi=off"?  Please try all three and post the results...thanks! 

Comment 2 John W. Linville 2005-07-06 19:39:40 UTC
Please do provide the requested information...additionally, test kernels w/ 
newest tg3 driver available here: 
 
   http://people.redhat.com/linville/kernels/rhel3/ 
 
Although you will not be able to install using them, it may be worth seeing if 
they get you farther along the process.  Please post your results...thanks! 

Comment 3 John W. Linville 2005-09-16 14:24:08 UTC
Closing due to lack of response.  Please re-open when requested information 
becomes available...thanks! 


Note You need to log in before you can comment on or make changes to this bug.