Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161150 - Spurious tomcat messages upon invoking help.
Summary: Spurious tomcat messages upon invoking help.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ben Konrath
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-20 20:36 UTC by Andrew Overholt
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-11-30 15:36:35 UTC


Attachments (Terms of Use)

Description Andrew Overholt 2005-06-20 20:36:26 UTC
Description of problem:
Spurious tomcat messages upon invoking help.

Version-Release number of selected component (if applicable):
>= eclipse-3.1.0_fc-0.M7.9

How reproducible:
Always

Steps to Reproduce:
1. Help -> Help Contents
  
Actual results:
Lots of messages like:

20-Jun-05 4:26:14 PM org.apache.catalina.startup.Embedded start()
INFO: Starting tomcat server
Created MBeanServer with ID: [UID:
737573713,1119299175047,-32768]:tophat.toronto.redhat.com:1
20-Jun-05 4:26:15 PM org.apache.catalina.core.StandardEngine start()
INFO: Starting Servlet Engine: Apache Tomcat/5.0
20-Jun-05 4:26:15 PM org.apache.catalina.core.StandardHost start()
INFO: XML validation disabled
20-Jun-05 4:26:15 PM org.apache.catalina.loader.WebappLoader start()
INFO: Dual registration of jndi stream handler: URLStreamHandlerFactory already set
20-Jun-05 4:26:15 PM org.apache.catalina.loader.WebappLoader setClassPath()
INFO: Unknown loader
org.eclipse.core.runtime.adaptor.EclipseClassLoader@311b8af1 class
org.eclipse.core.runtime.adaptor.EclipseClassLoader
20-Jun-05 4:26:17 PM org.apache.coyote.http11.Http11Protocol init()
INFO: Initializing Coyote HTTP/1.1 on http-59927
20-Jun-05 4:26:17 PM org.apache.coyote.http11.Http11Protocol start()
INFO: Starting Coyote HTTP/1.1 on http-59927
20-Jun-05 4:26:17 PM org.apache.catalina.core.StandardContext start()
WARNING: Error storing config file
UA: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524
Fedora/1.0.4-4 Firefox/1.0.4:, extra:  Firefox/1.0.4


Expected results:
Nothing echoed.

Additional info:
This is caused by my patch to make Eclipse use Tomcat 5.  I looked at the
differences that my patch introduced and didn't see what was causing the output
of tomcat to be echoed.  I didn't see anything at a quick glance, but that's
where the problem lies.  This doesn't affect functionality but should be fixed.

Comment 1 Ben Konrath 2006-11-30 15:12:05 UTC
I think that we shouldn't bother to fix this bug. Andrew, thoughts?

Comment 2 Andrew Overholt 2006-11-30 15:36:35 UTC
(In reply to comment #1)
> I think that we shouldn't bother to fix this bug. Andrew, thoughts?

Agreed.


Note You need to log in before you can comment on or make changes to this bug.