Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161121 - nss_ldap should strip newline from ldap.secret
Summary: nss_ldap should strip newline from ldap.secret
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: nss_ldap
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-20 17:36 UTC by Pierre Ossman
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 235
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-09 15:01:23 UTC


Attachments (Terms of Use)

Description Pierre Ossman 2005-06-20 17:36:34 UTC
Description of problem:
If the password in ldap.secret is terminated by a newline, this newline gets
sent to the server causing the bind to fail. Since every operation in nss_ldap
now uses the privileged bind all users are blocked from logging in.

It's fairly common that editors add a trailing newline so nss_ldap really should
handle this gracefully.


Version-Release number of selected component (if applicable):
234-4

How reproducible:
Every time.


Steps to Reproduce:
1. Configure a rootbinddn with a ldap.secret
2. Try getent passwd
  
Actual results:
Only local entries are shown.

Expected results:
All entries, including those on the LDAP server, are shown.

Comment 1 Nalin Dahyabhai 2005-09-09 15:01:23 UTC
This was fixed upstream in nss_ldap 235, closing because Raw Hide currently
features nss_ldap-240-2.


Note You need to log in before you can comment on or make changes to this bug.