Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161100 - gnome-panel ignores orientation setting (i.e. top, bottom)
Summary: gnome-panel ignores orientation setting (i.e. top, bottom)
Keywords:
Status: CLOSED DUPLICATE of bug 160439
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel
Version: 4
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-20 15:47 UTC by John Saalwaechter
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-27 16:32:20 UTC


Attachments (Terms of Use)

Description John Saalwaechter 2005-06-20 15:47:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
In FC4 I got rid of the default bottom panel,
then I set the "Orientation" property of the
default top panel to "Bottom". That moves that
panel down to the bottom for that session, but
the next time I login, the panel is at the top
again.  The Orientation property is still set
to Bottom after logging back in, but it's being
ignored.

The contents of $HOME/.gconf/apps/panel/toplevels/top_panel/%gconf.xml
do contain this after setting the property:

<?xml version="1.0"?>
<gconf>
        <entry name="y" mtime="1119280970" type="int" value="743">
        </entry>
        <entry name="orientation" mtime="1119280909" type="string">
                <stringvalue>bottom</stringvalue>
        </entry>
</gconf>

But this setting is ignored.

I have found that if I logout and choose "Save current setup",
then the property sticks properly. But shouldn't the orientation
be sticky without having to do that?

Version-Release number of selected component (if applicable):
gnome-panel-2.10.1-10

How reproducible:
Always

Steps to Reproduce:
1. Right-click on the top panel and choose Properties
2. Change Orientation from "Top" to "Bottom"
3. Logout then log back in
4. Panel is back to the top, but the Orientation property
is still set to "Bottom"
  

Expected Results:  Panel should have moved to the bottom permanently.

Additional info:

Workaround is to logout once using the "Save current settings" checkbox.

Comment 1 Mark McLoughlin 2005-06-27 16:32:20 UTC
This actually turns out to be a duplicate of bug #160439 - the WM is putting the
panel at the top of the screen if you've saved the session.

*** This bug has been marked as a duplicate of 160439 ***


Note You need to log in before you can comment on or make changes to this bug.