Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161088 - qt/kde can't print FC4 release notes
Summary: qt/kde can't print FC4 release notes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-20 14:59 UTC by Sammy
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 3.5.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-18 15:26:45 UTC


Attachments (Terms of Use)
a print patch for KDE (deleted)
2005-06-24 19:35 UTC, Sammy
no flags Details | Diff

Description Sammy 2005-06-20 14:59:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux; X11; en_US) KHTML/3.4.1 (like Gecko)

Description of problem:
True also with 3.3.4-14. 
 
When I try to print the default start page, which is the FC4 release notes, from 
konqueror it trys to print infinite number of pages (print to postscript flle), which 
I have to kill. 
 
Printing other web pages to postscript file worked fine! Must be some kind of a  
font problem in FC4 release notes. 

Version-Release number of selected component (if applicable):
qt-3.3.4-15

How reproducible:
Always

Steps to Reproduce:
1. Start konqueror 
2. print the default page to postscript file 
3. 
   

Additional info:

Comment 1 Ngo Than 2005-06-21 12:19:45 UTC
it seems a bug in kdelibs.

Comment 2 Anton Guda 2005-06-24 15:17:35 UTC
It seems to be a bug (156977) in qt3/gcc4 interaction. 
Namely: QLocale toString(double) coversion bug. 
it seems to be fixed in qt-3.3.4-14, but broked again in -15. 
This bug lead to bad conversion : double(14) -> "13.:" 
If need, testcase may be sent. 
 
P.S. Really it's a gcc4 bug ;-( 
 

Comment 3 Sammy 2005-06-24 15:40:22 UTC
I just test qt-3.3.4-14 from FC4 and it has the same problem. -14 fixed another problem 
with postscript printing but not the infinite loop problem. 
 
I'll check that bug # you mentioned. I also just rebuilt the kdelibs and kdebase rpms 
from the latest SVN 3.4 branch and the problem is still there. 

Comment 4 Sammy 2005-06-24 17:39:03 UTC
Since it is possible to print most documents except a few I tried to look into the FC4 index.html 
file. If one removes the css related stuff from the top of the file (of course the display looks 
different then) then it prints 3 pages and that is it. However, the postscript output is very 
very tiny, like 1pt, on the left side of the page (this is true even with the css stuff in if you 
look at the temp file created in /tmp/kde-user directory when in infinite loop). Does this mean 
it is a KDE bug? 

Comment 5 Sammy 2005-06-24 17:39:56 UTC
PS: the same bug is reported in kde.bugs for another html document. 

Comment 6 Sammy 2005-06-24 19:35:05 UTC
The following patch with the latest SVN no longer goes into infinite loop for
me.

However, the printed pages are tiny fonts such that even when magnified 1000%
still not as large as the original. This is uniqe to a few documents including
the FC4 release notes!

Comment 7 Sammy 2005-06-24 19:35:57 UTC
Created attachment 115950 [details]
a print patch for KDE

Comment 8 Sammy 2005-06-24 19:46:56 UTC
Sorry, that was not it!

When you turn uncheck "Print header" under the HTML Settings menu under the
print dialog, it does not seem to go into infinite loop.

Comment 9 Ngo Than 2006-01-18 15:26:45 UTC
it's not reproduceable in KDE-3.5.0.


Note You need to log in before you can comment on or make changes to this bug.