Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161080 - Missing BuildRequires dependency on desktop-file-utils
Summary: Missing BuildRequires dependency on desktop-file-utils
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: mozilla
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Christopher Aillon
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-20 14:32 UTC by Andreas Thienemann
Modified: 2008-02-01 14:35 UTC (History)
0 users

Fixed In Version: firefox-1.5.0.9-0.1.el4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-01 14:35:35 UTC


Attachments (Terms of Use)

Description Andreas Thienemann 2005-06-20 14:32:55 UTC
During a testbuild of mozilla-1.7.3-18.EL4 in mock, the rebuild process
stops with the following error:

+ desktop-file-install --vendor mozilla --dir
/var/tmp/mozilla-root/usr/share/applications --add-category X-Fedora --add-categ
ory Application --add-category Network /builddir/build/SOURCES/mozilla.desktop
/var/tmp/rpm-tmp.59503: line 234: desktop-file-install: command not found
error: Bad exit status from /var/tmp/rpm-tmp.59503 (%install)

Adding desktop-file-utils to the BuildRequires list should fix this problem.
Note: Even though I tested the SRPM from RHEL4, the same problem exists in rawhide.
The issue is the same as with the thunderbird package: desktop-file-utils is
already defined as a PreReq but it is needed for BuildPreReq as well.

Comment 1 Matěj Cepl 2008-02-01 14:35:35 UTC
Fixed in both RHEL4 and Rawhide.


Note You need to log in before you can comment on or make changes to this bug.