Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161075 - init scripts don't take into account current locale, only default system locale
Summary: init scripts don't take into account current locale, only default system locale
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 4
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
: 161062 161063 161064 161065 161066 161067 161069 161072 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-20 13:39 UTC by Dimitri Papadopoulos
Modified: 2014-03-17 02:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-20 16:48:46 UTC


Attachments (Terms of Use)

Description Dimitri Papadopoulos 2005-06-20 13:39:07 UTC
Description of problem:
The init scripts use the system default locale instead of the current locale.
This happens whether they include /etc/profile.d/lang.sh or not. The result is
that although I set LANG to see English output for debugging purposes, the
output is still in French, the default system locale:

# cat /ets/sysconfig/i18n
LANG="fr_FR.UTF-8"
SYSFONT="latarcyrheb-sun16"
SUPPORTED="en_US.UTF-8:en_US:en:fr_FR.UTF-8:fr_FR:fr:de_DE.UTF-8:de_DE:de:el_GR.UTF-8:el_GR:el:ko_KR.UTF-8:ko_KR:ko"
# 
# /etc/init.d/portmap status
portmap (pid 1785) en cours d'exécution...
# 

I think these scripts should honor the current locale because they're sometimes
run by the administrator for debugging purposes, not only at system startup.


Version-Release number of selected component (if applicable):
initscripts-8.11.1-1


How reproducible:
Every time.


Steps to Reproduce:
1. Set current locale to be different from the system default one.
2. Run an init script.


Actual results:
	# export LANG=C
	# /etc/init.d/ypbind status
	ypbind est arrêté
	# 


Expected results:
	# export LANG=C
	# /etc/init.d/ypbind status
	ypbind is stopped
	#

Comment 1 Miloslav Trmač 2005-06-20 14:15:00 UTC
*** Bug 161072 has been marked as a duplicate of this bug. ***

Comment 2 Miloslav Trmač 2005-06-20 14:15:08 UTC
*** Bug 161062 has been marked as a duplicate of this bug. ***

Comment 3 Miloslav Trmač 2005-06-20 14:15:20 UTC
*** Bug 161064 has been marked as a duplicate of this bug. ***

Comment 4 Miloslav Trmač 2005-06-20 14:15:34 UTC
*** Bug 161066 has been marked as a duplicate of this bug. ***

Comment 5 Miloslav Trmač 2005-06-20 14:15:34 UTC
*** Bug 161065 has been marked as a duplicate of this bug. ***

Comment 6 Miloslav Trmač 2005-06-20 14:15:56 UTC
*** Bug 161063 has been marked as a duplicate of this bug. ***

Comment 7 Miloslav Trmač 2005-06-20 14:16:01 UTC
*** Bug 161067 has been marked as a duplicate of this bug. ***

Comment 8 Miloslav Trmač 2005-06-20 14:16:18 UTC
*** Bug 161069 has been marked as a duplicate of this bug. ***

Comment 9 Bill Nottingham 2005-06-20 16:48:46 UTC
This means that the output of a script would change based on how the user may
have configured their language, as opposed to being generally consistent across
the system. That could surprise users; as such, I'm not sure I'd want to make
this change now. Perhaps once http://fedoraproject.org/wiki/FCNewInit is in
place, this could be revisited.


Note You need to log in before you can comment on or make changes to this bug.