Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161068 - netdump doesn't work
Summary: netdump doesn't work
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: netdump
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Anderson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-20 12:11 UTC by JM
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-20 15:10:04 UTC


Attachments (Terms of Use)

Description JM 2005-06-20 12:11:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
netdump doesn't start. I get always the error message

--------------------
# /etc/init.d/netdump start
initializing netdump FATAL: Module netdump not found.
                                                           [FAILED]
initializing netconsole FATAL: Error inserting netconsole (/lib/modules/2.6.11-1.1369_FC4/kernel/drivers/net/netconsole.ko): Invalid argument
                                                           [FAILED]
--------------------

So it can't find the module netdump and can't load the module netconsole.

Version-Release number of selected component (if applicable):
netdump-0.7.7-6 kernel-2.6.11-1.1369_FC4

How reproducible:
Always

Steps to Reproduce:
1. Edit /etc/sysconfig/netdump and add the NETDUMPADDR=
2. Then start netdump with "service netdump start"

Additional info:

Comment 4 Dave Anderson 2005-06-20 15:10:04 UTC

Netdump is not supported in this kernel version; note that Patch1501 and
Patch1502 have been disabled:

# Netdump and Diskdump bits.
Patch1500: linux-2.6.10-crashdump-common.patch
Patch1501: linux-2.6.10-netdump.patch
Patch1502: linux-2.6.8-netconsole.patch
Patch1503: linux-2.6.10-diskdump.patch

# netdump bits
%patch1500 -p1
# Netdump is broken right now. It applies, but not with -F1. Its h0rked. Leave
it off.
#%patch1501 -p1
#%patch1502 -p1
%patch1503 -p1

An updated patch set has been forwarded to the kernel maintainer for inclusion
in a subsequent kernel update.


Comment 5 Jan "Yenya" Kasprzak 2007-05-25 16:35:16 UTC
This bug has been CLOSED NEXTRELEASE for two years (reported on FC4), but the
problem still exists on FC5 (bug #201436, which is probably a duplicate of this
bug), FC6, and even the current rawhide kernel
kernel-2.6.21-1.3189.fc7.x86_64.rpm still does not have a netdump.o module.

Dave, which "NEXTRELEASE" did you mean? Please reopen this bug for FC6, or at
least be fair and change it to CLOSED WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.