Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161060 - Clusvcmgrd doesn't finish starting cups service script
Summary: Clusvcmgrd doesn't finish starting cups service script
Keywords:
Status: CLOSED DUPLICATE of bug 143867
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: clumanager
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-20 11:27 UTC by Jorge Izquierdo
Modified: 2009-04-16 20:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-23 17:41:11 UTC


Attachments (Terms of Use)

Description Jorge Izquierdo 2005-06-20 11:27:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
When starting CUPS service in a cluster configuration with clumanger the service starts two cups daemons but doesn't ends correctly, and the processes:

sh /etc/init.d/cups start and
clusvcmgrd

stays in memory until I manually stop the cups service from /etc/init.d/cups stop.

The service is defined in the cluster.xml file as:

    <service checkinterval="0" failoverdomain="None" id="1" name="Printer" userscript="/etc/init.d/cups">
      <service_ipaddresses/>
    </service>
  </services>

The script works well when called directly from a shell in the machine, 

Version-Release number of selected component (if applicable):
clumanager-1.2.16-1

How reproducible:
Always

Steps to Reproduce:
1. Defining a service in the cluster with init script /etc/init.d/cups
2. Enable the service in one node with: clusvcadm -e <Service_Name>
3. Check the status of the service and the log to test that actually is not working as it should be if the CUPS service was started manually without cluster control:  ps -ef | grep cups
4. Tail /var/log/cluster to see log messages from cluster software
5. ps -ef | grep clus to see the processes of the cluster running


  

Actual Results:  3. ps -ef | grep cups

root      2648  2640  0 13:15 ?        00:00:00 /bin/sh /etc/init.d/cups start
root      2653  2648  0 13:15 ?        00:00:00 initlog -q -c cupsd
root      2654  2653  0 13:15 ?        00:00:00 cupsd
root      2655  2654  1 13:15 ?        00:00:00 cupsd
root      2728 28267  0 13:15 pts/0    00:00:00 grep cups



4. tail /var/log/cluster

Jun 20 12:50:42 pcXXX clusvcmgrd[1592]: <debug> [C] Pid 1592 handling start request for service Printer
Jun 20 12:50:42 pcXXX clusvcmgrd[1592]: <debug> Starting service 1 - flags 0x00000001
Jun 20 12:50:42 pcXXX clusvcmgrd[1592]: <debug> Handling start request for service Printer
Jun 20 12:50:42 pcXXX clusvcmgrd[3273]: <debug> [M] Pid 1592 -> start for service Printer
Jun 20 12:50:42 pcXXX clusvcmgrd[1592]: <notice> Starting disabled service Printer
Jun 20 12:50:42 pcXXX clusvcmgrd[1592]: <debug> Exec of script /usr/lib/clumanager/services/service, action start, service Printer
Jun 20 12:50:42 pcXXX clusvcmgrd: [1593]: <notice> service notice: Starting service Printer ...
Jun 20 12:50:42 pcXXX clusvcmgrd: [1593]: <notice> service notice: Running user script '/etc/init.d/cups start'
Jun 20 12:51:39 pcXXX clusvcmgrd: [1593]: <notice> service notice: Started service Printer ...


5. ps -ef | grep clus

root      3273     1  0 Jun16 ?        00:00:25 /usr/sbin/clusvcmgrd
root      2576   785  0 13:15 pts/0    00:00:00 clusvcadm -e Printer
root      2577  3273  0 13:15 ?        00:00:00 /usr/sbin/clusvcmgrd





Expected Results:  3. ps -ef | grep cups

root      2161     1  3 13:09 ?        00:00:00 cupsd

4. tail /var/log/cluster

Jun 20 12:50:42 pcXXX clusvcmgrd[1592]: <debug> [C] Pid 1592 handling start request for service Printer
Jun 20 12:50:42 pcXXX clusvcmgrd[1592]: <debug> Starting service 1 - flags 0x00000001
Jun 20 12:50:42 pcXXX clusvcmgrd[1592]: <debug> Handling start request for service Printer
Jun 20 12:50:42 pcXXX clusvcmgrd[3273]: <debug> [M] Pid 1592 -> start for service Printer
Jun 20 12:50:42 pcXXX clusvcmgrd[1592]: <notice> Starting disabled service Printer
Jun 20 12:50:42 pcXXX clusvcmgrd[1592]: <debug> Exec of script /usr/lib/clumanager/services/service, action start, service Printer
Jun 20 12:50:42 pcXXX clusvcmgrd: [1593]: <notice> service notice: Starting service Printer ...
Jun 20 12:50:42 pcXXX clusvcmgrd: [1593]: <notice> service notice: Running user script '/etc/init.d/cups start'
Jun 20 12:51:39 pcXXX clusvcmgrd: [1593]: <notice> service notice: Started service Printer ...
Jun 20 12:51:39 pcXXX clusvcmgrd[1592]: <debug> Exec of script for service Printer returned 0

5. ps -ef | grep clus

root      3273     1  0 Jun16 ?        00:00:25 /usr/sbin/clusvcmgrd

Additional info:

The version of CUPS used: cups-1.1.17-13.3.13

It seems as if the init script hangs executing /usr/sbin/cupsd when it is called by the service manager of the cluster, and the the clusvcmgrd daemon stays in memory waiting for the success exit status of the script. I have tested this with a start clause that only executes /usr/bin/cupsd and then exit 0. It works smoothly when called from a root shell but hangs when called from service manager of the cluster manager suite (clusvcadm -e Printer).

Comment 1 Lon Hohberger 2005-06-20 17:27:01 UTC
Please update to 1.2.26.1, which fixes an issue where signals were blocked in
started services.

Comment 2 Jorge Izquierdo 2005-06-21 10:02:23 UTC
(In reply to comment #1)
> Please update to 1.2.26.1, which fixes an issue where signals were blocked in
> started services.

Sorry I can't find such version of the package, is it published for IA32 i386?
Where can I find it or its associated SRPM? I found 1.2.22-2 but it still has
the same behaviour with cups script.

Thanks for your help.

Comment 4 Jorge Izquierdo 2005-06-23 11:54:21 UTC
Upppssss, I can't get this link with my login account, it gives me a permission
error. I have no systems or channels configured in my RHN profile because I'm
using it only for testing purposes. Is there any other way or link where I could
get the package to test if this solves my problem?

Thanks in advance for your help



Comment 5 Lon Hohberger 2005-06-23 16:47:08 UTC
Hmm, your sales engineer can give you official packages if you're an evaluation
customer.  In the mean time, there are a few options:

(a) This patch should apply against your 1.2.22 tree:

https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=109260

(b) You can use the older 1.2.24-0.1 packages (which include this fix) from the
original bugzilla concerning blocked signals in services:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=143867

(c) You can rebuild the source RPM from updates.redhat.com:

http://updates.redhat.com/enterprise/3ES/en/RHCS/SRPMS/clumanager-1.2.26.1-1.src.rpm

Comment 6 Jorge Izquierdo 2005-06-23 17:41:11 UTC
I have updated to version 1.2.24 from the second link and it works. Thanks, I
will look forwad latest version



*** This bug has been marked as a duplicate of 143867 ***

Comment 7 Bouraoui 2006-03-06 13:40:45 UTC
well, I have the same error: <debug> Exec of script
/usr/lib/clumanager/services/service, action stop, service oracle_cluster and I
have clumanager 1.2.26.1-1 ? , my service is the oracle database script.
N.B: I use Bonding methode for acrive passive network.


Comment 8 Lon Hohberger 2007-12-21 15:10:11 UTC
Fixing product name.  Clumanager on RHEL3 was part of RHCS3, not RHEL3


Note You need to log in before you can comment on or make changes to this bug.