Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161059 - swap_free: bad swap file entry (x86-64)
Summary: swap_free: bad swap file entry (x86-64)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
: 161419 (view as bug list)
Depends On: 163437
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-20 11:21 UTC by Vincent Sweeney
Modified: 2015-01-04 22:20 UTC (History)
3 users (show)

Fixed In Version: 2.6.12-1.1372_FC3smp
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-02 16:44:37 UTC


Attachments (Terms of Use)

Description Vincent Sweeney 2005-06-20 11:21:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
To fix the " mm/memory.c:98: bad pmd " error on a SMP Opteron (dual-core) x86 sytem on the latest 2.6.11-1.27_FC3smp kernel bugzilla suggests running davej's latest devel kernel rpm's. However after running for an amount of time the server now oops. So far, the longest uptime is 6 hours before death.


Version-Release number of selected component (if applicable):
kernel-smp-2.6.11-1.35_FC3

How reproducible:
Always

Steps to Reproduce:
1. Basically run any application that puts the system under load.
2. Run app for a few hours.
  

Additional info:

Jun 18 14:56:24 ec09-dc01 kernel: swap_free: Bad swap file entry 4000000000000000
Jun 18 14:56:24 ec09-dc01 kernel: ----------- [cut here ] --------- [please bite here ] ---------
Jun 18 14:56:24 ec09-dc01 kernel: Kernel BUG at rmap:482
Jun 18 14:56:24 ec09-dc01 kernel: invalid operand: 0000 [4] SMP
Jun 18 14:56:24 ec09-dc01 kernel: CPU 1
Jun 18 14:56:24 ec09-dc01 kernel: Modules linked in: md5 ipv6 nbd dm_mod video button battery ac ohci_hcd tg3 floppy sg ext3 jbd aic79xx sd_mod scsi_mod
Jun 18 14:56:24 ec09-dc01 kernel: Pid: 10412, comm: sh Tainted: G    B 2.6.11-1.35_FC3smp
Jun 18 14:56:24 ec09-dc01 kernel: RIP: 0010:[<ffffffff801755a6>] <ffffffff801755a6>{page_remove_rmap+38}

Comment 1 Dave Jones 2005-07-08 00:23:45 UTC
*** Bug 161419 has been marked as a duplicate of this bug. ***

Comment 2 Dave Jones 2005-07-15 19:59:42 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 3 Vincent Sweeney 2005-07-17 18:25:56 UTC
Installed the new kernel-smp-2.6.12-1.1372_FC3.x86_64.rpm package but the server
now dies due to a kernel panic during boot / startup. No log just yet as this
was tested via remote hands.

I will try to schedule a reboot to test the non-smp / i686 versions and get full
error log 'soon'.

Comment 4 Vincent Sweeney 2005-07-18 13:12:17 UTC
kernel-2.6.12-1.1372_FC3.x86_64.rpm installed and boots fine. 12 hours uptime
under load so far with no 'bad pmd' or oops which is a marked improvement over
previous versions.

However the x86_64-SMP kernel still fails to boot, hope to test the i686-smp
version later.





Comment 5 Vincent Sweeney 2005-07-21 01:29:03 UTC
Well I guess I can't test the smp version (!) until bug 163437 is resolved ....

Comment 6 Vincent Sweeney 2005-08-02 16:45:30 UTC
kernel 2.6.12-1.1372_FC3smp seems to fix all issues previously seen.

Comment 7 Konstantin Olchanski 2005-08-02 22:11:30 UTC
Negative. I just booted kernel 2.6.12-1.1372_FC3smp and had two panics with
"swap_free: Bad swap file entry", see
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=164941
K.O.



Note You need to log in before you can comment on or make changes to this bug.