Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161050 - Installer waits forever when upgrading from FC2 using DVD image
Summary: Installer waits forever when upgrading from FC2 using DVD image
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-20 08:56 UTC by Håvard Dahle
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-23 15:51:53 UTC


Attachments (Terms of Use)
/tmp/anaconda.log from the failed install (deleted)
2005-06-20 09:00 UTC, Håvard Dahle
no flags Details
/tmp/syslog from the failed install (deleted)
2005-06-20 09:00 UTC, Håvard Dahle
no flags Details
Some additional files that may be relevant (deleted)
2005-06-20 09:08 UTC, Håvard Dahle
no flags Details

Description Håvard Dahle 2005-06-20 08:56:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
I try to upgrade a Dell Precision 670 that has two scsi disks, one of which has FC2. However, anaconda waits indefinately when she tries to figure out what packages to upgrade. This is both when installing from a DVD (the actual medium) and when installing from the DVD .iso (harddisk install).

Curiously, upgrading from FC3 *CD*s works smoothly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start FC4 install process on the machine
2. Click through all steps until anaconda starts calculating which packages to upgrade.
3. anaconda loops indefinately
  

Actual Results:  I was not able to upgrade

Expected Results:  I should have been able to upgrade FC2->FC4

Additional info:

I have attached /tmp/anaconda.log, /tmp/syslog and some others I pray be useful. 

I have categorized this in 'Severity: high' because this bug efficiently makes it impossible to upgrade.

Comment 1 Håvard Dahle 2005-06-20 09:00:03 UTC
Created attachment 115678 [details]
/tmp/anaconda.log from the failed install

This is the contents of /tmp/anaconda.log from when the installer waits
indefinately. This is from a hard drive install from the DVD *image* (not disc)

Comment 2 Håvard Dahle 2005-06-20 09:00:41 UTC
Created attachment 115679 [details]
/tmp/syslog from the failed install

This is the contents of /tmp/syslog from when the installer waits indefinately.
This is from a hard drive install from the DVD *image* (not disc)

Comment 3 Håvard Dahle 2005-06-20 09:08:04 UTC
Created attachment 115680 [details]
Some additional files that may be relevant

This zip archive contains
/etc/mtab
/mnt/sysimage/etc/fstab
the output of fdisk -l /dev/sd{a,b}

I do not know whether this is useful. 

Also, sorry about the crappy gunzip-in-zip mess. Had to go through that
horrible WinZip thing to send it.

Comment 4 Håvard Dahle 2005-06-20 09:26:21 UTC
FWIW, some additional data points.

This ISO image has been used successfully twice before: one upgrade from FC2, 
one clean install - so it's not corrupted.

Also, regarding the issues in this ticket, the upgrade path FC2->FC3->FC4 
solved them. That is, the troubles reported above only surfaced on _this one_ 
computer, and only on a _FC2 upgrade_. 

This lead me to believe that maybe the physical hard drive layout was to blame, 
that's why I attached the fstab/mtab/fdisk info. But it is all very confusing 
to me. I hope you can figure it out. Good luck :)

Oh, and thanks for all the hard work already. FC4 is cool once it's in there.


Comment 5 Jeremy Katz 2005-06-20 18:15:35 UTC
There's nothing obviously wrong there... FC2->FC4 is going to take longer to
figure out because of the way dependencies and package layout have changed. 
It's likely it would have worked if you had left it going.

Would I be right to assume you can't try again and see if it goes as you already
did ->fc3->fc4?

Comment 6 Håvard Dahle 2005-06-23 07:19:26 UTC
Ah, but I did another FC2->FC4 upgrade, and there was no delay to speak of ( < 1
min). This time we're talking > 5 mins. (The other upgrade was from an NFS
mounted image, this upgrade was from local disk as it is the NFS server.)

Re question #2: You are correct, I have no means to try it again. I am sorry.

Comment 7 Jeremy Katz 2005-06-23 15:51:53 UTC
The amount of time depends on exactly what packages were installed, the speed of
the system, etc.  I can definitely see it taking a little while in some cases
and I think that's just what you hit.


Note You need to log in before you can comment on or make changes to this bug.