Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161042 - apt is not able to download the list of mirrors
Summary: apt is not able to download the list of mirrors
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: apt
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 154681 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-20 06:59 UTC by Matteo Corti
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: 0.5.15cnc7-6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-23 05:31:55 UTC


Attachments (Terms of Use)

Description Matteo Corti 2005-06-20 06:59:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
"apt mirror-select" is not able to download the list of mirrors (http://www.fedora.us/mirrorlists/fedora.us-fc4-mirrors.list), which is missing.


Version-Release number of selected component (if applicable):
apt-0.5.15cnc7-2

How reproducible:
Always

Steps to Reproduce:
1. apt-get mirror-select
  

Actual Results:  Fetching list of repositories/mirrors...
E: Failed to fetch mirror list file:



Expected Results:  Choice of mirrors

Additional info:

Comment 1 Panu Matilainen 2005-06-21 20:16:47 UTC
Yup, known thing. The problem is this:
- there's no "approved" place for FC4 apt repositories since fedora.us doesn't
want to provide it anymore
- we can't include freshrpms/dag etc apt repositories to the mirror lists
because of US legalese, AFAICT

So what we have is a lose-lose situation really - we need to drop the
mirror-list functionality from apt since we can't include any repositories in
there, and without any included repositories the apt package in extras is going
to look pretty bad compared to those offered by 3rd party repositories.

Ville, unless you have better ideas I think we need to just kill mirror-select
in the extras package :-/

Comment 2 Matteo Corti 2005-06-21 20:23:07 UTC
I am not involved in the issue but if you don't want to drop the mirror-select feature you could begin to 
set the first run option to false so that apt will work with hand edited source files. At the moment apt is 
ignoring sources because no mirrors are set using mirror-select.

Comment 3 Panu Matilainen 2005-06-21 20:28:44 UTC
Even we you default to not running it on the first run, mirror-select will still
show up in apt-get --help output and people expect it to do something useful
which it doesn't. So unless we can come up with some "politically correct"
repositories to include in the mirror lists it's better to just drop the
functionality completely I think.

Comment 4 Matteo Corti 2005-06-21 20:30:52 UTC
Yes, in fact I think you are right. It would be nonsense to have if there is no way to have an official site 
where to put the list of mirrors ...

Comment 5 Panu Matilainen 2005-06-21 20:42:44 UTC
Note that the problem is not about hosting the mirrorlist itself, I could easily
host that on my site. The problem is the repositories themselves: apt repos for
fc4 do exist, but all the ones I know about carry software which isn't legally
ok in the US so packages in extras (and core) can't even link to those sites. :-/

Comment 6 Matteo Corti 2005-06-21 20:47:24 UTC
Yes but this is true only for additional repositories. RedHat could provide a repository for the core, 
updates and extras packages (everything official and legal). Sites as freshrpms could mirror it, or as they 
do now just allow to use their Fedora mirror with apt.

Comment 7 Ville Skyttä 2005-06-21 21:32:27 UTC
My .02â¬, but it's really Panu's call: leave the mirror-select functionality 
in, but have only a commented out example or two, possibly pointing to bogus 
sites in mirror-select.conf.  Perhaps also include a sample actual mirror list 
or two in the package as %doc, again pointing to bogus sites if we can't find 
working ones that can be included. 
 
Dunno what should be done with the Macromedia mirror list, it's kinda 
related... WDYT?  If "keep": Warren, would it be possible to host it on 
macromedia.mplug.org, or will it stay available at www.fedora.us? 
   
BTW, I've removed the fedora.us key and vendors.list entry in my local working  
dir, will remove them in the next package revision unless there's a reason  
not to. 

Comment 8 Panu Matilainen 2005-06-22 05:22:38 UTC
I'd rather see the mirror-list thing gone completely than pointing it to bogus
sites or such, it's going to look just as bad that way ("it doesn't work")
Also having a mirror list which only points to Macromedia mirrors is going to
look awfully weird. If we can't find *real* sites we can point to with FC4
repositories, remove the thing. For all I know it only ever confused users
anyway based on what I've seen in fedora-list.

Removing fedora.us keys is ok by me, there's nothing there anymore AFAIK.

Comment 9 Ville Skyttä 2005-06-22 05:55:05 UTC
Fair enough.  Unless someone reports usable mirror sites by tomorrow, I'll 
build an update with all of that stuff removed. 

Comment 10 Ville Skyttä 2005-06-23 05:31:55 UTC
Done in CVS and FC4 build requested. 

Comment 11 Panu Matilainen 2005-06-27 18:32:06 UTC
*** Bug 154681 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.