Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161038 - up2date can cause packages to be installed twice
Summary: up2date can cause packages to be installed twice
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: up2date
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
: 170753 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-20 05:21 UTC by petrosyan
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-07 02:47:03 UTC


Attachments (Terms of Use)

Description petrosyan 2005-06-20 05:21:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
After installing a fresh copy of Fedora Core 4 and running up2date to update the system I ended up with two versions of NetworkManager.

Version-Release number of selected component (if applicable):
Fedora Core 4

How reproducible:
Always

Steps to Reproduce:
1. install a fresh copy of Fedora Core 4
2. run up2date to update the system
3. run 'rpm -q NetworkManager'
  

Actual Results:  $ rpm -q NetworkManager
NetworkManager-0.4-15.cvs20050404
NetworkManager-0.4-18.FC4

Expected Results:  $ rpm -q NetworkManager
NetworkManager-0.4-18.FC4


Additional info:

Comment 1 Bill Nottingham 2005-06-20 16:31:55 UTC
Check your update log for any scripts failing during the upgrade - are there any?

Comment 2 petrosyan 2005-06-20 21:10:56 UTC
Here is the error message:
error: %postun(NetworkManager-0.4-15.cvs20050404.i386) scriptlet failed, exit
status 126

I also found an easy way to reproduce this bug:
1. uninstall all NetworkManager related packages
2. download and install via 'rpm -i NetworkManager-0.4-15.cvs20050404.i386.rpm'
from http://download.fedora.redhat.com/pub/fedora/linux/core/4/i386/os/Fedora/RPMS/
3. now run up2date, and update NetworkManager
4. see an error message in the terminal
5. run 'rpm -q NetworkManager' and see 2 different versions of NetworkManager

Comment 3 Andre Robatino 2005-06-24 19:22:48 UTC
  I also noticed this, though I've never used this package.  I removed the older
version with
"rpm -e NetworkManager-0.4-15.cvs20050404", and when verifying the remaining
version with "rpm -V NetworkManager", found a bunch of files missing, which are
listed below.  I then reinstalled it with "rpm -Uvh --replacepkgs
NetworkManager-0.4-18.FC4.i386.rpm", and after this it verified properly.

missing     /usr/share/doc/NetworkManager-0.4
missing   d /usr/share/doc/NetworkManager-0.4/AUTHORS
missing   d /usr/share/doc/NetworkManager-0.4/CONTRIBUTING
missing   d /usr/share/doc/NetworkManager-0.4/COPYING
missing   d /usr/share/doc/NetworkManager-0.4/ChangeLog
missing   d /usr/share/doc/NetworkManager-0.4/NEWS
missing   d /usr/share/doc/NetworkManager-0.4/README
missing   d /usr/share/doc/NetworkManager-0.4/TODO
missing     /usr/share/locale/bs/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/cs/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/da/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/de/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/el/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/en_CA/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/es/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/fr/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/gu/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/hr/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/it/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/ja/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/nb/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/nl/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/no/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/pa/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/pt_BR/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/rw/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/sk/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/sq/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/sv/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/uk/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/wa/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/zh_CN/LC_MESSAGES/NetworkManager.mo
missing     /usr/share/locale/zh_TW/LC_MESSAGES/NetworkManager.mo

Comment 4 Andre Robatino 2005-06-24 21:39:18 UTC
  After making sure the new packages were installed properly, I tried
downgrading the NetworkManager (and NetworkManager-gnome, since they're
interdependent) packages using "rpm -Uvh --oldpackage
NetworkManager-0.4-15.cvs20050404.i386.rpm
NetworkManager-gnome-0.4-15.cvs20050404.i386.rpm", and then upgrading them to
the new versions again.  This time it upgraded properly with no duplicate.  Strange.

Comment 5 petrosyan 2005-06-25 04:24:27 UTC
It is because you used "rpm -Uvh" to upgrade.
If you use up2date for upgrading you will end up again with 2 versions of
NetworkManager as described in comment #2

Comment 6 Andre Robatino 2005-07-18 12:26:47 UTC
  See also bug #163500 which involves up2date causing two versions of audit to
be installed.

Comment 7 Andre Robatino 2005-07-18 13:58:09 UTC
  Since there are at least two different package that up2date causes to be
installed twice, this bug should probably be moved to up2date.

Comment 8 petrosyan 2005-07-18 14:30:45 UTC
If you update a freshly installed Fedora Core 4 system by running up2date you
end up with 2 copies of NetworkManager and audit.
To reproduce this bug:
1. install a new Fedora Core 4 system
2. up2date it.
3. run:
$rpm -q NetworkManager audit


Comment 9 Andre Robatino 2005-07-26 14:23:24 UTC
  Here's a case where up2date installed the latest nfs-utils update twice.

http://www.redhat.com/archives/fedora-list/2005-July/msg04987.html

Comment 10 Andre Robatino 2005-09-26 20:26:28 UTC
  I just noticed that there were 2 versions of vixie-cron installed:

vixie-cron-4.1-33
vixie-cron-4.1-36.FC4

  I uninstalled 4.1-33 and then repaired 4.1-36 using rpm -Uvh --replacepkgs.

Comment 11 Damian Menscher 2005-10-09 22:36:20 UTC
Seeing this on RHEL4.1 trying to update to RHEL4.2.  Results in 164 duplicated
packages, with no easy fix.  What's the status of this bug??

It's worth noting that using FC as a beta test of RHEL doesn't help if you don't
ever fix the bugs in FC....

Comment 12 Andre Robatino 2005-10-14 18:25:17 UTC
  This appears related to bug #170753 where the same thing happens with yum.

Comment 13 Andre Robatino 2005-12-10 18:43:16 UTC
  See also bug #175431.

Comment 14 petrosyan 2006-01-07 02:47:03 UTC
this bug is not relevant anymore because Fedora Core 5 removed up2date

Comment 15 Jeremy Katz 2006-04-19 20:13:32 UTC
*** Bug 170753 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.