Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161037 - chroot segv on rescue cd
Summary: chroot segv on rescue cd
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: busybox
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-20 05:17 UTC by Daryll
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-21 13:56:09 UTC


Attachments (Terms of Use)

Description Daryll 2005-06-20 05:17:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
I booted the FC4 rescue CD on a RH EL WS 3.0 system with the hopes of fixing a corrupted boot loader. The rescue disc boots fine, but when I tried to chroot /mnt/sysimage it segfaulted. I also tried chroot /mnt/sysimage /bin/ls and that segfaulted as well.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot the rescue cd
2. chroot /mnt/sysimage
3.
  

Actual Results:  
segfault and no chroot

Expected Results:  New shell chroot'ed

Additional info:

Comment 1 Daryll 2005-06-21 14:58:16 UTC
I suspect the issue is mixing the two OS versions. Did you test the mismatched
versions?

The reason I think that might be the problem, is that I just updated my FC3
system to the packages in updates-testing and now if I attempt to boot any of my
old kernels (2.6.11-1.27 for example) it reports a core dump very early in the
init process. If I boot the kernel 2.6.11-1.35 (which is also in updates
testing) then everything works fine.

We needed a rescue disc from FC4 because it had SATA drivers that aren't in EL3.
Maybe this isn't supposed to work?

Comment 2 Ivana Varekova 2005-06-22 06:43:19 UTC
I test fc4 rescue CD on a RHEL3 system and it works fine. Probably there is some
mistake on the system you want to chroot which causes this error. 


Note You need to log in before you can comment on or make changes to this bug.